summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-15 20:57:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-15 22:40:04 +0100
commita9db93c10f38b6cecfebb068726666ea2ce8d614 (patch)
tree8203456af2bc0fb6fbbd0fc2793516291f249c4d /gnu/packages/game-development.scm
parent75f66e4a391dde51300376b98e676f555591c244 (diff)
downloadguix-patches-a9db93c10f38b6cecfebb068726666ea2ce8d614.tar
guix-patches-a9db93c10f38b6cecfebb068726666ea2ce8d614.tar.gz
gnu: python-pygame: Update to 1.9.4.
* gnu/packages/game-development.scm (python-pygame): Update to 1.9.4. [arguments]: Re-indent.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 08b84f07fa..25935aafcc 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -857,16 +857,16 @@ interface (API).")
(define-public python-pygame
(package
(name "python-pygame")
- (version "1.9.3")
+ (version "1.9.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "pygame" version))
(sha256
(base32
- "1hlydiyygl444bq5m5g8n3jsxsgrdyxlm42ipmfbw36wkf0j243m"))))
+ "1dn0nb86jl7yr8709cncxdr0yrmviqakw7zx3g8jbbwrr60if3bh"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; Tests require pygame to be installed first.
+ `(#:tests? #f ; tests require pygame to be installed first
#:phases
(modify-phases %standard-phases
;; Set the paths to the dependencies manually because
@@ -891,23 +891,23 @@ interface (API).")
(substitute* "Setup.in"
(("FONT = -lSDL_ttf")
(string-append "FONT = -I" font-ref "/include/SDL -L"
- font-ref "/lib -lSDL_ttf")))
+ font-ref "/lib -lSDL_ttf")))
(substitute* "Setup.in"
(("IMAGE = -lSDL_image")
(string-append "IMAGE = -I" image-ref "/include/SDL -L"
- image-ref "/lib -lSDL_image")))
+ image-ref "/lib -lSDL_image")))
(substitute* "Setup.in"
(("MIXER = -lSDL_mixer")
(string-append "MIXER = -I" mixer-ref "/include/SDL -L"
- mixer-ref "/lib -lSDL_mixer")))
+ mixer-ref "/lib -lSDL_mixer")))
(substitute* "Setup.in"
(("SMPEG = -lsmpeg")
(string-append "SMPEG = -I" smpeg-ref "/include/smpeg -L"
- smpeg-ref "/lib -lsmpeg")))
+ smpeg-ref "/lib -lsmpeg")))
(substitute* "Setup.in"
(("PNG = -lpng")
(string-append "PNG = -I" png-ref "/include -L"
- png-ref "/lib -lpng")))
+ png-ref "/lib -lpng")))
(substitute* "Setup.in"
(("JPEG = -ljpeg")
(string-append "JPEG = -I" jpeg-ref "/include -L"