summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-09 21:23:22 +0200
committerMarius Bakke <marius@gnu.org>2022-08-10 00:29:00 +0200
commit9fda25caff4f7e7df375dec44804c4cebb1a0643 (patch)
tree3a7d6a835d2f328c19279e0f08237d02ba2e770c /gnu/packages/game-development.scm
parent00962dd18f21270daaaf9a5b7c7cc995d8f6402f (diff)
downloadguix-patches-9fda25caff4f7e7df375dec44804c4cebb1a0643.tar
guix-patches-9fda25caff4f7e7df375dec44804c4cebb1a0643.tar.gz
gnu: box2d: Unbundle doctest.
* gnu/packages/game-development.scm (box2d)[source](snippet): Delete doctest, and adjust accordingly. [native-inputs]: Add DOCTEST.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 090e7f7d12..3e0301a199 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2020, 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2019 Jethro Cao <jethrocao@gmail.com>
@@ -2467,13 +2467,23 @@ rigid body physics library written in C.")
(modules '((guix build utils)))
(snippet
'(begin
- ;; Bundled code only used for the testbed.
- (delete-file-recursively "extern")))))
+ ;; Remove bundled code only used for the testbed.
+ (delete-file-recursively "extern")
+ ;; Remove bundled copy of doctest, and adjust tests accordingly.
+ (delete-file "unit-test/doctest.h")
+ (substitute* "unit-test/CMakeLists.txt"
+ (("doctest\\.h")
+ ""))
+ (substitute* (find-files "unit-test" "\\.cpp$")
+ (("include \"doctest\\.h\"")
+ "include <doctest/doctest.h>"))))))
(build-system cmake-build-system)
(arguments
`(#:test-target "unit_test"
#:configure-flags '("-DBUILD_SHARED_LIBS=ON"
"-DBOX2D_BUILD_TESTBED=OFF")))
+ (native-inputs
+ (list doctest)) ;for tests
(inputs
(list libx11))
(home-page "https://box2d.org/")