summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-24 21:26:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-24 21:26:58 +0100
commit9a6b8c9fa36bca5541336d61685ebdea10654ce4 (patch)
treeb42a107e88f9d9d127e5fe16bbbcb4b71f7446f8 /gnu/packages/game-development.scm
parent4e3a7d84613e4caeca903a205f21707cff5819f7 (diff)
parentaa51eb2073f17e40d660d0beaeb7b1b78aa9e1cc (diff)
downloadguix-patches-9a6b8c9fa36bca5541336d61685ebdea10654ce4.tar
guix-patches-9a6b8c9fa36bca5541336d61685ebdea10654ce4.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ac01cb3f2f..7f00f7080b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1005,28 +1005,21 @@ painted with a mouse.")
(define-public ois
(package
(name "ois")
- (version "1.3")
+ (version "1.5")
(source
(origin
- ;; Development has moved to github and there are no recent tarball
- ;; releases.
(method git-fetch)
(uri (git-reference
(url "https://github.com/wgois/OIS.git")
- (commit "bb75ccc1aabc1c547195579963601ff6080ca2f2")))
- (file-name (string-append name "-" version))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0w0pamjc3vj0jr718hysrw8x076fq6n9rd6wcb36sn2jd0lqvi98"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("m4" ,m4)
- ("pkg-config" ,pkg-config)))
+ (base32 "0g8krgq5bdx2rw7ig0xva4kqv4x815672i7z6lljp3n8847wmypa"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
(inputs
- `(("libxaw" ,libxaw)))
+ `(("libx11" ,libx11)))
(synopsis "Object Oriented Input System")
(description
"Cross Platform Object Oriented Input Lib System is a cross platform,