summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-11-17 14:47:46 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-11-30 18:19:32 +0530
commit92b51d127fa66a9f6cb59a2a295518c3487d705c (patch)
tree66b40fcf4c3a3914a5fcfce3ba5a303b7f11764e /gnu/packages/game-development.scm
parent9364a520ce617424b7548f3688787a66b89d6a05 (diff)
downloadguix-patches-92b51d127fa66a9f6cb59a2a295518c3487d705c.tar
guix-patches-92b51d127fa66a9f6cb59a2a295518c3487d705c.tar.gz
gnu: godot: Use scons-build-system.
* gnu/packages/game-development.scm (godot): Switch to scons-build-system.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm45
1 files changed, 20 insertions, 25 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index be241cbd31..3c544f5546 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -37,6 +37,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system scons)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
@@ -1063,12 +1064,26 @@ games.")
(file-name (string-append name "-" version))
(sha256
(base32 "1mz89nafc1m7srbqvy7iagxrxmqvf5hbqi7i0lwaapkx6q0kpkq7"))))
- (build-system gnu-build-system)
+ (build-system scons-build-system)
(arguments
- `(#:tests? #f ; There are no tests
+ `(#:scons ,scons-python2
+ #:scons-flags (list "platform=x11"
+ ;; Avoid using many of the bundled libs.
+ ;; Note: These options can be found in the SConstruct file.
+ "builtin_freetype=no"
+ "builtin_glew=no"
+ "builtin_libmpdec=no"
+ "builtin_libogg=no"
+ "builtin_libpng=no"
+ "builtin_libtheora=no"
+ "builtin_libvorbis=no"
+ "builtin_libwebp=no"
+ "builtin_openssl=no"
+ "builtin_opus=no"
+ "builtin_zlib=no")
+ #:tests? #f ; There are no tests
#:phases
(modify-phases %standard-phases
- (delete 'configure)
(add-after 'unpack 'scons-use-env
(lambda _
;; Scons does not use the environment variables by default,
@@ -1079,24 +1094,6 @@ games.")
"env_base = Environment(tools=custom_tools)\n"
"env_base = Environment(ENV=os.environ)")))
#t))
- (replace 'build
- (lambda _
- (zero? (system*
- "scons"
- "platform=x11"
- ;; Avoid using many of the bundled libs.
- ;; Note: These options can be found in the SConstruct file.
- "builtin_freetype=no"
- "builtin_glew=no"
- "builtin_libmpdec=no"
- "builtin_libogg=no"
- "builtin_libpng=no"
- "builtin_libtheora=no"
- "builtin_libvorbis=no"
- "builtin_libwebp=no"
- "builtin_openssl=no"
- "builtin_opus=no"
- "builtin_zlib=no"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1128,8 +1125,7 @@ games.")
Type=Application~%"
out)))
#t))))))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("scons" ,scons)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("alsa-lib" ,alsa-lib)
("freetype" ,freetype)
("glew" ,glew)
@@ -1144,8 +1140,7 @@ games.")
("mesa" ,mesa)
("openssl" ,openssl)
("opusfile" ,opusfile)
- ("pulseaudio" ,pulseaudio)
- ("python2" ,python-2)))
+ ("pulseaudio" ,pulseaudio)))
(home-page "https://godotengine.org/")
(synopsis "Advanced 2D and 3D game engine")
(description