summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-20 22:25:04 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-20 23:11:44 +0100
commit83010a08bc7347d0969fa0acea2cd9ab421ed6d5 (patch)
treef114ba0486b5fd1ed40c4c494ff4672081dfb410 /gnu/packages/game-development.scm
parentc34bb6b310ec17bfa4cd9f412a0c44b419ce8f75 (diff)
downloadguix-patches-83010a08bc7347d0969fa0acea2cd9ab421ed6d5.tar
guix-patches-83010a08bc7347d0969fa0acea2cd9ab421ed6d5.tar.gz
gnu: grafx2: Build with '-fcommon'.
* gnu/packages/game-development.scm (grafx2)[arguments]: Add '-fcommon' to #:make-flags.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index fd504b1a6e..6aef26388a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1625,7 +1625,8 @@ also comes with a built-in image and sound editor.")
;; SDL header files are referenced without the preceeding "SDL/".
(list (string-append "CFLAGS=-I"
(assoc-ref %build-inputs "sdl-union")
- "/include/SDL")
+ "/include/SDL"
+ " -fcommon")
(string-append "prefix="
(assoc-ref %outputs "out")))
#:tests? #f)) ; no check target