summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2021-11-18 15:24:01 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-11-20 12:16:11 +0100
commit60bb03605af73c7af60274ecc5e07d79d63a285e (patch)
tree3c03b4d63237892c148c19ab7d3c1cd23ecbb4b6 /gnu/packages/game-development.scm
parentb7a515c5102d0c463bfdcd064e5946ffc8936725 (diff)
downloadguix-patches-60bb03605af73c7af60274ecc5e07d79d63a285e.tar
guix-patches-60bb03605af73c7af60274ecc5e07d79d63a285e.tar.gz
gnu: Add libresprite.
* gnu/packages/game-development.scm (libresprite): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 51ec4a5fc2..55bbad30e6 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1016,6 +1017,59 @@ the creation of animations, tiled graphics, texture atlases, and more.")
(home-page "https://www.aseprite.org/")
(license license:gpl2+)))
+(define-public libresprite
+ (package
+ (name "libresprite")
+ (version "1.0")
+ ;; TODO: Unbundle third party software.
+ ;; - duktape is bundled inside the project but it's hard to unbundle:
+ ;; there are many differences from a version to the next and it is not
+ ;; really designed to work as a shared lib.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LibreSprite/LibreSprite")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0djbjjh21ahlxzh0b0jp4mpfycam8h9157i4wbxkd618fraadhbp"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ (list "-DWITH_WEBP_SUPPORT=1")
+ ;; Tests are unmaintained
+ #:tests? #f))
+ (native-inputs
+ `(("gcc@10" ,gcc-10) ; Requires 8.5 or higher
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("freetype" ,freetype)
+ ("giflib" ,giflib)
+ ("googletest" ,googletest)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libwebp" ,libwebp)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxxf86dga" ,libxxf86dga)
+ ("libxxf86vm" ,libxxf86vm)
+ ("lua" ,lua) ; Optional
+ ("pixman" ,pixman)
+ ("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("tinyxml" ,tinyxml)
+ ("zlib" ,zlib)))
+ (synopsis "Animated sprite editor and pixel art tool")
+ (description "LibreSprite is a tool for creating 2D pixel art for video
+games. In addition to basic pixel editing features, it can assist in the
+creation of animations, tiled graphics, texture atlases, and more.
+LibreSprite is a fork of the latest GPLv2 commit of Aseprite.")
+ (home-page "https://libresprite.github.io/")
+ (license license:gpl2+)))
+
(define-public qqwing
(package
(name "qqwing")