summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-10 17:20:27 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-10 17:20:27 +0200
commit5464af0765ea922f9ba4791a3f41552776006ae7 (patch)
tree602f96149fb7c24d7034b97025bd5d0e5cd20a49 /gnu/packages/game-development.scm
parentc4595fdedf027b9be6733cac8b2e3ee82cdcb16a (diff)
downloadguix-patches-5464af0765ea922f9ba4791a3f41552776006ae7.tar
guix-patches-5464af0765ea922f9ba4791a3f41552776006ae7.tar.gz
gnu: tsukundere: Update to 0.4.1.
* gnu/packages/game-development.scm (tsukundere): Update to 0.4.1. [#:phases]<patch-command>: Use tsukundere.scm instead of the now missing bin/tsukundere. [inputs]: Add pango and sdl2. [native-inputs]: Add libtool.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 4e2605eafa..01db2364df 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -560,7 +560,7 @@ clone.")
(define-public tsukundere
(package
(name "tsukundere")
- (version "0.3.2")
+ (version "0.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -569,7 +569,7 @@ clone.")
(file-name (git-file-name name version))
(sha256
(base32
- "05y3nj8vpn40hfr2y29p8pa9hhpzibhbvfzpm0dlphjh9crq3ii4"))))
+ "11glghnff27rqh2s34g51afg93g3f5ryfz9mkyb7qj35ngl8vw5f"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 match)
@@ -599,7 +599,7 @@ clone.")
((label . pkg)
(and (string-prefix? "guile-" label) pkg)))
inputs))))
- (substitute* "bin/tsukundere"
+ (substitute* "tsukundere.scm"
(("exec guile (.*)" _ args)
(string-append
(format #f "export GUILE_LOAD_PATH=\"~@?\"~%"
@@ -615,11 +615,14 @@ clone.")
("automake" ,automake)
("gettext" ,gettext-minimal)
("guile" ,guile-3.0)
+ ("libtool" ,libtool)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
(inputs
`(("guile-sdl2" ,guile3.0-sdl2)
- ("guile" ,guile-3.0)))
+ ("guile" ,guile-3.0)
+ ("pango" ,pango)
+ ("sdl2" ,sdl2)))
(home-page "https://gitlab.com/lilyp/tsukundere")
(synopsis "Visual novel engine")
(description "Tsukundere is a game engine geared heavily towards the