summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-08 01:25:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-08 02:30:25 +0200
commit49405aaf5c2c9cfc713c7efdccaf6d48d3c714a3 (patch)
treea764aaae60075ba960ab1b948574d8b6e9bbb6ea /gnu/packages/game-development.scm
parent9828859c29ebe9908a4336a8512f61453f928902 (diff)
downloadguix-patches-49405aaf5c2c9cfc713c7efdccaf6d48d3c714a3.tar
guix-patches-49405aaf5c2c9cfc713c7efdccaf6d48d3c714a3.tar.gz
gnu: allegro: Update to 5.2.5.0.
* gnu/packages/game-development.scm (allegro): Update to 5.2.5.0. [source]: Remove patch. * gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f6f23a116e..63ccd20470 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -684,19 +684,17 @@ etc.")
(define-public allegro
(package
(name "allegro")
- (version "5.2.4.0")
+ (version "5.2.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/liballeg/allegro5/releases"
"/download/" version "/allegro-"
version ".tar.gz"))
- (patches (search-patches
- "allegro-mesa-18.2.5-and-later.patch"))
(sha256
(base32
- "1w9a5yqi5q03b2qvmx5ff90paz0xbr9cy7i7f0xiqa65ava66q9l"))))
+ "06dpkfnac8w3pq36834nn2iij3ajz6prladqd0w92lq39aiqv5jr"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; there are no tests
+ (arguments `(#:tests? #f)) ; there are no tests
(inputs
;; FIXME: Add the following optional inputs: xinput2, opensl, dumb
`(("flac" ,flac)