summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-20 16:55:06 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-05-20 17:02:39 +0200
commit47f4d5d32f6519ef133fa6188c12d872b346734a (patch)
tree7f058e0a4135d3d3576e228b1dc0e67d7f363d9c /gnu/packages/game-development.scm
parentce7a966295d541f4f804e9579ad99aba052c19c4 (diff)
downloadguix-patches-47f4d5d32f6519ef133fa6188c12d872b346734a.tar
guix-patches-47f4d5d32f6519ef133fa6188c12d872b346734a.tar.gz
gnu: mygui: Don't use unstable tarball.
* gnu/packages/game-development.scm (mygui)[source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Disable Windows-specific demos and tools.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5dd22215b8..a3585630f0 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1037,13 +1037,14 @@ robust and compatible with many systems and operating systems.")
(version "3.2.2")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/MyGUI/" name
- "/archive/MyGUI" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MyGUI/mygui")
+ (commit (string-append "MyGUI" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "13x7cydmj7gjmsg702sqjbfi53z265iv6j7binv3r6a7ibndfa0a"))))
+ "1wk7jmwm55rhlqqcyvqsxdmwvl70bysl9azh4kd9n57qlmgk3zmw"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; No test target
@@ -1051,7 +1052,11 @@ robust and compatible with many systems and operating systems.")
(list "-DMYGUI_INSTALL_DOCS=TRUE"
(string-append "-DOGRE_INCLUDE_DIR="
(assoc-ref %build-inputs "ogre")
- "/include/OGRE"))))
+ "/include/OGRE")
+ ;; Demos and tools are Windows-specific:
+ ;; https://github.com/MyGUI/mygui/issues/24.
+ "-DMYGUI_BUILD_DEMOS=FALSE"
+ "-DMYGUI_BUILD_TOOLS=FALSE")))
(native-inputs
`(("boost" ,boost)
("doxygen" ,doxygen)