summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-05 02:09:33 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-05 02:13:18 +0100
commit45c552ec516f2c502e9e44f0cde26d73a7ebdb1d (patch)
tree8bc5d2147029cc68a18f909953d55c1983b44f38 /gnu/packages/game-development.scm
parentfe0686864dc57ecdda7ecbb318d2618ac46169ae (diff)
downloadguix-patches-45c552ec516f2c502e9e44f0cde26d73a7ebdb1d.tar
guix-patches-45c552ec516f2c502e9e44f0cde26d73a7ebdb1d.tar.gz
gnu: Add libccd.
* gnu/packages/game-development.scm (libccd): New variable.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index cfe271075a..24c75b1e3e 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Jethro Cao <jethrocao@gmail.com>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -82,6 +83,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages stb)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
@@ -1956,3 +1958,32 @@ focuses solely on developing a fully accurate XNA4 runtime for the desktop.")
license:lgpl2.1 ; LzxDecoder.cs
;; Mono.Xna:
license:expat))))
+
+(define-public libccd
+ (package
+ (name "libccd")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danfis/libccd.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sfmn5pd7k5kyhbxnd689xmsa5v843r7sska96dlysqpljd691jc"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DBUILD_DOCUMENTATION=ON"
+ "-DBUILD_TESTING=ON"
+ "-DENABLE_DOUBLE_PRECISION=ON")))
+ (native-inputs
+ `(("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/danfis/libccd")
+ (synopsis "Library for collision detection between two convex shapes")
+ (description "@code{libccd} is library for a collision detection
+between two convex shapes. @code{libccd} implements variation on
+Gilbert–Johnson–Keerthi algorithm plus Expand Polytope Algorithm (EPA)
+and also implements algorithm Minkowski Portal Refinement (MPR,
+a.k.a. XenoCollide) as described in Game Programming Gems 7.")
+ (license license:expat)))