summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-07-02 14:46:28 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-07-15 13:13:40 +0200
commit3d7dea0906a59ff84308907b1488da52956a614c (patch)
tree435339380c146ef736969334d828dac8b4c6b7c6 /gnu/packages/game-development.scm
parenta613e6268de9864fe8ea9e72415b8fe4eea9a4d9 (diff)
downloadguix-patches-3d7dea0906a59ff84308907b1488da52956a614c.tar
guix-patches-3d7dea0906a59ff84308907b1488da52956a614c.tar.gz
gnu: python2-renpy: Correct inputs.
* gnu/packages/game-development.scm (python2-renpy)[#:phases]<fix-commands>: Search for ‘xdg-open’ in inputs. <set-build-vars>: Search for ‘cython’ in native-inputs. [native-inputs]: Move ‘xdg-utils’ from here… [inputs]: … to here.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9b231ad333..7c5d45c412 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1186,10 +1186,11 @@ developed mainly for Ren'py.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-commands
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "renpy/editor.py"
(("xdg-open")
- (which "xdg-open")))
+ (string-append (assoc-ref inputs "xdg-utils")
+ "/bin/xdg-open")))
#t))
(add-after 'unpack 'fix-include-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -1199,9 +1200,10 @@ developed mainly for Ren'py.")
"/include/fribidi")))
#t))
(add-after 'set-paths 'set-build-vars
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
(setenv "RENPY_CYTHON"
- (string-append (assoc-ref inputs "python2-cython")
+ (string-append (assoc-ref (or native-inputs inputs)
+ "python2-cython")
"/bin/cython"))
(setenv "RENPY_DEPS_INSTALL" (string-join (map cdr inputs) ":"))
#t))
@@ -1240,14 +1242,14 @@ developed mainly for Ren'py.")
("glew" ,glew)
("libpng" ,libpng)
("sdl-union"
- ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+ ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))
+ ("xdg-utils" ,xdg-utils)))
(propagated-inputs
`(("python2-future" ,python2-future)
("python2-pygame" ,python2-pygame-sdl2)))
(native-inputs
`(("gcc" ,gcc-8) ; for const variables as initializer elements
- ("python2-cython" ,python2-cython)
- ("xdg-utils" ,xdg-utils)))
+ ("python2-cython" ,python2-cython)))
(home-page "https://www.renpy.org/")
(synopsis "Ren'py python module")
(description "This package contains the shared libraries and Python modules