summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-30 04:03:54 -0400
committerMark H Weaver <mhw@netris.org>2018-04-30 04:03:54 -0400
commit3d5ad159b336a9903b31d0be7ae052dbc8d5bfcc (patch)
treeee7dce4e436490a1db5f18e4bfad55511d2fff32 /gnu/packages/game-development.scm
parentc77835db04ee20c0afe20600dc8f91a67bc2421e (diff)
parent8c21c64e59d3f4d223d8aeef91f06fdde7de1ab7 (diff)
downloadguix-patches-3d5ad159b336a9903b31d0be7ae052dbc8d5bfcc.tar
guix-patches-3d5ad159b336a9903b31d0be7ae052dbc8d5bfcc.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm27
1 files changed, 24 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 3b7db9caef..3ff27b4a1b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1059,16 +1060,34 @@ games.")
(define-public godot
(package
(name "godot")
- (version "3.0.1")
+ (version "3.0.2")
(source (origin
(method url-fetch)
(uri
(string-append "https://github.com/godotengine/godot/archive/"
version "-stable.tar.gz"))
- (file-name (string-append name "-" version))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0k8c12nzhl98i9il9s3awbwdamkrwxk0s47jr7n8a3z93rpszd2p"))))
+ "0ldnk3j4w2kh454mzclmq8nk7zqrn758yrqq85i4kzljpkf93g0m"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Drop libraries that we take from Guix. Note that some
+ ;; of these may be modified; see "thirdparty/README.md".
+ (with-directory-excursion "thirdparty"
+ (for-each delete-file-recursively
+ '("freetype"
+ "libogg"
+ "libpng"
+ "libtheora"
+ "libvorbis"
+ "libvpx"
+ "libwebp"
+ "openssl"
+ "opus"
+ "zlib"))
+ #t)))))
(build-system scons-build-system)
(arguments
`(#:scons ,scons-python2
@@ -1086,6 +1105,7 @@ games.")
"builtin_libpng=no"
"builtin_libtheora=no"
"builtin_libvorbis=no"
+ "builtin_libvpx=no"
"builtin_libwebp=no"
"builtin_openssl=no"
"builtin_opus=no"
@@ -1141,6 +1161,7 @@ games.")
("glu" ,glu)
("libtheora" ,libtheora)
("libvorbis" ,libvorbis)
+ ("libvpx" ,libvpx)
("libwebp" ,libwebp)
("libx11" ,libx11)
("libxcursor" ,libxcursor)