summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:28:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit2aab587f842908a886e3bd08b028885dddd650e0 (patch)
tree87c0723a9ae2c69ab6920d90b6e87ad8510492fe /gnu/packages/game-development.scm
parent5664bcdcb0e4c10dfe48dd5e4730fc3c746a21e2 (diff)
parent65c46e79e0495fe4d32f6f2725d7233fff10fd70 (diff)
downloadguix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar
guix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 68ed9b2364..1ae69d5c4d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -529,7 +529,7 @@ clone.")
all)))
#t))))))
(native-inputs
- `(("autoconf" ,autoconf-wrapper)
+ `(("autoconf" ,autoconf)
("automake" ,automake)
("guile" ,guile-3.0)
("pkg-config" ,pkg-config)
@@ -638,7 +638,7 @@ sounds from presets such as \"explosion\" or \"powerup\".")
(define-public surgescript
(package
(name "surgescript")
- (version "0.5.4.4")
+ (version "0.5.5")
(source
(origin
(method git-fetch)
@@ -647,12 +647,13 @@ sounds from presets such as \"explosion\" or \"powerup\".")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1vck1wk6r6jrrw5xzpqldplz601dfgpk5s5p45fam00nfsid0p7p"))))
+ (base32 "0xwd4g7n0b0rxkpbyshkzyl472h1y606ghyvf8gv034n3jz2g4jk"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
(let ((share (string-append (assoc-ref %outputs "out") "/share")))
- (list (string-append "-DICON_PATH=" share "/pixmaps")
+ (list "-DWANT_STATIC=NO"
+ (string-append "-DICON_PATH=" share "/pixmaps")
(string-append "-DMETAINFO_PATH=" share "/metainfo")))
#:tests? #f))
(home-page "https://docs.opensurge2d.org")
@@ -2393,7 +2394,7 @@ game engine. id Tech 2 is the engine originally behind Quake 2.")
(define-public dhewm3
(package
(name "dhewm3")
- (version "1.5.0")
+ (version "1.5.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2401,7 +2402,7 @@ game engine. id Tech 2 is the engine originally behind Quake 2.")
version "/dhewm3-" version "-src.tar.xz"))
(sha256
(base32
- "0dmd1876az5q8gbjrd1jk8zidz11ydj607z3m8m5kvw2yj136jzv"))))
+ "0s2brx6wyljhjbpli97iy4lc4fqqsvdc09raz8njg0vgzcsiyrri"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; No tests.