summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-09-09 20:40:40 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-09-09 20:59:14 -0400
commit2110cd1332aee5439c32413f01483055ef91b339 (patch)
tree11f052658d3cf2dd0c492997bb0f8e59a111ce01 /gnu/packages/game-development.scm
parent762c89fb20faf84796113239ea6254e51c4d73fa (diff)
downloadguix-patches-2110cd1332aee5439c32413f01483055ef91b339.tar
guix-patches-2110cd1332aee5439c32413f01483055ef91b339.tar.gz
gnu: python-xsge: Update to 2020.09.07.
* gnu/packages/game-development.scm (python-xsge): Update to 2020.09.07. [native-inputs]: Add unzip. [propagated-inputs]: Remove python-game, python-six, and python-tmx. Use python-sge instead of python-sge-pygame. [home-page]: Update URL. (python2-xsge): Remove unsupported Python 2 variant.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 0f48803f41..c8e0e94099 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -408,14 +408,15 @@ levels.")
(define-public python-xsge
(package
(name "python-xsge")
- (version "2018.02.26")
+ (version "2020.09.07")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://savannah/xsge/xsge/xsge-"
- version ".tar.gz"))
+ (uri (string-append "https://github.com/python-sge/xsge"
+ "/releases/download/v" version
+ "/xsge-" version ".zip"))
(sha256
(base32
- "0bx93hgf7cgdw2gsygbh59y8vpw37pgsa279rajw3fkdpl8vrc40"))))
+ "136xgy3f9vw636wxpqbha022avk0wyxw63mm3a2dvwhh90s716f9"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -428,12 +429,11 @@ levels.")
(string-append "--prefix=" (assoc-ref outputs "out"))
"--root=/"))))
#:tests? #f)) ; no check target
+ (native-inputs
+ `(("unzip" ,unzip)))
(propagated-inputs
- `(("python-sge-pygame" ,python-sge-pygame)
- ("python-pygame" ,python-pygame)
- ("python-six" ,python-six)
- ("python-tmx" ,python-tmx)))
- (home-page "http://xsge.nongnu.org")
+ `(("python-sge" ,python-sge)))
+ (home-page "https://python-sge.github.io/")
(synopsis "Extensions for the SGE Game Engine")
(description
"xSGE is a collection of modules that make doing certain tasks with the SGE
@@ -442,9 +442,6 @@ GUI toolkit, lighting and physics frameworks and @code{Tiled} TMX format
support.")
(license license:gpl3+)))
-(define-public python2-xsge
- (package-with-python2 python-xsge))
-
(define-public tiled
(package
(name "tiled")