summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-10 17:33:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-10 17:33:58 +0200
commit127c7fba1aee2a547cd4653cb548c3eed9a699ee (patch)
tree77c1c1e356b37b5becdf8a69271d68a21b88edca /gnu/packages/game-development.scm
parentc0f297e85f37034e6fc8249966d3a7167951a3dd (diff)
downloadguix-patches-127c7fba1aee2a547cd4653cb548c3eed9a699ee.tar
guix-patches-127c7fba1aee2a547cd4653cb548c3eed9a699ee.tar.gz
gnu: grfcodec: Fix source URL.
* gnu/packages/game-development.scm (grfcodec)[source]: Use HTTPS for URL. Re-indent package.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 785447644c..b899c2fe6c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -191,39 +191,39 @@ DeuTex has functions such as merging wads, etc.")
(package
(name "grfcodec")
(version "6.0.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://binaries.openttd.org/extra/"
- name "/" version "/" name "-" version
- "-source.tar.xz"))
- (sha256
- (base32
- "08admgnpqcsifpicbm56apgv360fxapqpbbsp10qyk8i22w1ivsk"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://binaries.openttd.org/extra/"
+ name "/" version "/" name "-" version
+ "-source.tar.xz"))
+ (sha256
+ (base32 "08admgnpqcsifpicbm56apgv360fxapqpbbsp10qyk8i22w1ivsk"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no check target
+ '(#:tests? #f ;no check target
#:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (replace 'install ; no install target
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (doc (string-append out "/share/doc"))
- (man (string-append out "/share/man/man1")))
- (for-each (lambda (file)
- (install-file file bin))
- '("grfcodec" "grfid" "grfstrip" "nforenum"))
- (install-file "COPYING" doc)
- (with-directory-excursion "docs"
- (for-each (lambda (file)
- (install-file (string-append file ".txt") doc))
- '("auto_correct" "commands" "grf" "grfcodec" "grftut"
- "readme" "readme.rpn"))
- (for-each (lambda (file)
- (install-file file man))
- (find-files "." "\\.1"))))
- #t)))))
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install ;no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (doc (string-append out "/share/doc"))
+ (man (string-append out "/share/man/man1")))
+ (for-each (lambda (file)
+ (install-file file bin))
+ '("grfcodec" "grfid" "grfstrip" "nforenum"))
+ (install-file "COPYING" doc)
+ (with-directory-excursion "docs"
+ (for-each (lambda (file)
+ (install-file (string-append file ".txt") doc))
+ '("auto_correct" "commands" "grf" "grfcodec" "grftut"
+ "readme" "readme.rpn"))
+ (for-each (lambda (file)
+ (install-file file man))
+ (find-files "." "\\.1"))))
+ #t)))))
(inputs
`(("boost" ,boost)
("libpng" ,libpng)