summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-14 15:08:12 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-18 00:36:08 +0200
commit0bc272480019a5c2ff34dd13bd4c8f3450970f8d (patch)
tree99ed345de3909c7faee676d26152db95fb1578cf /gnu/packages/game-development.scm
parent08e977d291a5426be15f0ddb204a3a7004bd9e92 (diff)
downloadguix-patches-0bc272480019a5c2ff34dd13bd4c8f3450970f8d.tar
guix-patches-0bc272480019a5c2ff34dd13bd4c8f3450970f8d.tar.gz
gnu: sfml: Update to 2.5.0.
* gnu/packages/game-development.scm (sfml): Update to 2.5.0. [arguments]: Specify pkg-config dir in #:configure-flags. [native-inputs]: Add PKG-CONFIG. [inputs]: Move FLAC, FREETYPE, LIBVORBIS and OPENAL ... [propagated-inputs]: ... here. New field.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index fde139c0b7..4610e389bd 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -440,7 +440,7 @@ clone.")
(define-public sfml
(package
(name "sfml")
- (version "2.3.2")
+ (version "2.5.0")
(source (origin
(method url-fetch)
;; Do not fetch the archives from
@@ -451,24 +451,29 @@ clone.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0k2fl5xk3ni2q8bsxl0551inx26ww3w6cp6hssvww0wfjdjcirsm"))))
+ "1x3yvhdrln5b6h4g5r4mds76gq8zsxw6icxqpwqkmxsqcq5yviab"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- (list "-DSFML_INSTALL_PKGCONFIG_FILES=TRUE")
+ (list "-DSFML_INSTALL_PKGCONFIG_FILES=TRUE"
+ "-DSFML_OS_PKGCONFIG_DIR=lib/pkgconfig")
#:tests? #f)) ; no tests
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("mesa" ,mesa)
("glew" ,glew)
- ("flac" ,flac)
- ("libvorbis" ,libvorbis)
("libx11" ,libx11)
("xcb-util-image" ,xcb-util-image)
("libxrandr" ,libxrandr)
("eudev" ,eudev)
- ("freetype" ,freetype)
("libjpeg" ,libjpeg)
- ("libsndfile" ,libsndfile)
+ ("libsndfile" ,libsndfile)))
+ (propagated-inputs
+ ;; In Requires.private of pkg-config files.
+ `(("flac" ,flac)
+ ("freetype" ,freetype)
+ ("libvorbis" ,libvorbis)
("openal" ,openal)))
(home-page "https://www.sfml-dev.org")
(synopsis "Simple and Fast Multimedia Library")