summaryrefslogtreecommitdiff
path: root/gnu/packages/fvwm.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-01-17 17:10:17 +0800
committer宋文武 <iyzsong@gmail.com>2015-01-17 17:11:55 +0800
commitc1b0c7d9769b356ef246791b6cf8b70f34014d45 (patch)
treedb5a1c79abb358a793f7f1ad9e2068357a5621f7 /gnu/packages/fvwm.scm
parent80650d7719ff59ad366dca41209130486b71e9e0 (diff)
downloadguix-patches-c1b0c7d9769b356ef246791b6cf8b70f34014d45.tar
guix-patches-c1b0c7d9769b356ef246791b6cf8b70f34014d45.tar.gz
gnu: Add fvwm.
* gnu/packages/fvwm.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/fvwm.scm')
-rw-r--r--gnu/packages/fvwm.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/fvwm.scm b/gnu/packages/fvwm.scm
new file mode 100644
index 0000000000..b994fbf6b6
--- /dev/null
+++ b/gnu/packages/fvwm.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fvwm)
+ #:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages fribidi)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg))
+
+(define-public fvwm
+ (package
+ (name "fvwm")
+ (version "2.6.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.fvwm.org/pub/fvwm/version-2/fvwm-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1ks8igvmzm0m0sra05k8xzc8vkqy3gv1qskl6davw1irqnarjm11"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
+ (inputs
+ `(("fribidi" ,fribidi)
+ ("libpng" ,libpng)
+ ("librsvg" ,librsvg)
+ ("libxcursor" ,libxcursor)
+ ("libxext" ,libxext)
+ ("libxft" ,libxft)
+ ("libxinerama" ,libxinerama)
+ ("libxpm" ,libxpm)
+ ("libxt" ,libxt)
+ ("readline" ,readline)))
+ (synopsis "Virtual window manager for X11")
+ (description
+ "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
+window manager for the X Window system.")
+ (home-page "http://www.fvwm.org/")
+ (license gpl2+)))