summaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-10-04 17:01:23 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-04 17:02:29 +0200
commitf88d78b4310cdfc6d77f5c03a9e968f09dcce310 (patch)
tree49a1f7ea371b401804490e8d32f4051a88af3b17 /gnu/packages/ftp.scm
parentdf897e1dae8fd5b70a1ab9de53a6b1521cf2c417 (diff)
downloadguix-patches-f88d78b4310cdfc6d77f5c03a9e968f09dcce310.tar
guix-patches-f88d78b4310cdfc6d77f5c03a9e968f09dcce310.tar.gz
gnu: ncftp: Fix compiling with gcc 10.
* gnu/packages/ftp.scm (ncftp)[arguments]: Add '-fcommon' to CFLAGS.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 17ad139162..0dd6958e51 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -132,6 +133,7 @@ reliability in mind.")
(let ((out (assoc-ref outputs "out")))
(setenv "CONFIG_SHELL" (which "sh"))
(setenv "SHELL" (which "sh"))
+ (setenv "CFLAGS" "-fcommon")
(invoke "./configure"
(string-append "--prefix=" out))))))
#:tests? #f)) ;there are no tests