summaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-10-19 17:00:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-10-19 19:34:17 +0200
commitf5d377326840837e4d66f26ad4de58a974980609 (patch)
treee9f8b0e53afd0c4d27a46be33596253b29435c0f /gnu/packages/ftp.scm
parentc17b5986f2fd6ebf100d1a2e6de85b9b5a98b463 (diff)
downloadguix-patches-f5d377326840837e4d66f26ad4de58a974980609.tar
guix-patches-f5d377326840837e4d66f26ad4de58a974980609.tar.gz
gnu: ncftp: Use ‘modify-phases’.
* gnu/packages/ftp.scm (ncftp): Use the ‘modify-phases’ syntax.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 8ef620ce76..e1e6191d03 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -100,18 +100,18 @@ reliability in mind.")
"free software"))))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This is an old 'configure' script that doesn't
- ;; understand variables passed as arguments.
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "sh"))
- (setenv "SHELL" (which "sh"))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))
- %standard-phases)
- #:tests? #f)) ;there are no tests
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; This is an old 'configure' script that doesn't
+ ;; understand variables passed as arguments.
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (setenv "SHELL" (which "sh"))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)))))))
+ #:tests? #f)) ;there are no tests
(inputs `(("ncurses" ,ncurses)))
(home-page "http://www.ncftp.com/ncftp/")
(synopsis "Command-line File Transfer Protocol (FTP) client")