summaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-07 03:45:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-07 13:54:50 +0200
commitdf7ebbd9bd7c430ee396295ddde1ba32f45af246 (patch)
tree11d3a9e4ece458d8eb155bcd41ad29c9b65b56f4 /gnu/packages/ftp.scm
parent19e6c4445f09606bfda72b2f36582021951e1e9c (diff)
downloadguix-patches-df7ebbd9bd7c430ee396295ddde1ba32f45af246.tar
guix-patches-df7ebbd9bd7c430ee396295ddde1ba32f45af246.tar.gz
gnu: filezilla, libfilezilla: Update to 3.50.0, 0.24.1.
* gnu/packages/ftp.scm (libfilezilla): Update to 0.24.1. [native-inputs]: Add gettext-minimal. [inputs]: Add gnutls. (filezilla): Update to 3.50.0.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 651e732ab3..13ebe6bff4 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -170,20 +170,22 @@ as required.")
(define-public libfilezilla
(package
(name "libfilezilla")
- (version "0.16.0")
+ (version "0.24.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.filezilla-project.org/"
"libfilezilla/libfilezilla-" version ".tar.bz2"))
(sha256
- (base32 "1fd71vmllzvljff5l5ka5wnzbdsxx4i54dpxpklydmbsqpilnv1v"))))
+ (base32 "1zfnqbn14dx0fl45mfaznr5n5xsxy1kx8z9f80fppbqn37pb9mgx"))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
+ ("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(inputs
- `(("nettle" ,nettle)))
+ `(("gnutls" ,gnutls)
+ ("nettle" ,nettle)))
(home-page "https://lib.filezilla-project.org")
(synopsis "Cross-platform C++ library used by Filezilla client")
(description
@@ -208,14 +210,14 @@ output.
(define-public filezilla
(package
(name "filezilla")
- (version "3.42.1")
+ (version "3.50.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.filezilla-project.org/client/"
"FileZilla_" version "_src.tar.bz2"))
(sha256
- (base32 "083ycsycwy1szhp3mzf998wsqa74hmdxdsy07x6k81vp2cxjxijg"))))
+ (base32 "042w2f5cf8g9cr7d3m6294ygx7jggcria9502jnql855khk8gnz0"))))
(build-system gnu-build-system)
(arguments
;; Don't let filezilla phone home to check for updates.