summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-17 00:08:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-17 00:08:34 +0200
commitf5961dd5854cec1ed9a41365836d63aa15256642 (patch)
tree9e6168827adf5e4e90128d55fad6f0ab6448c86a /gnu/packages/freedesktop.scm
parent05bb85fda06dc361b8d3d1eef0759606784b3130 (diff)
parente28ff04108ae7506a21d451cc23d63937076e2a3 (diff)
downloadguix-patches-f5961dd5854cec1ed9a41365836d63aa15256642.tar
guix-patches-f5961dd5854cec1ed9a41365836d63aa15256642.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm40
1 files changed, 27 insertions, 13 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 25d93fd28d..a84cb3b97a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -54,12 +54,14 @@
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib) ;intltool
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
@@ -74,6 +76,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages video)
#:use-module (gnu packages w3m)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
@@ -628,7 +631,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public weston
(package
(name "weston")
- (version "5.0.0")
+ (version "6.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -636,30 +639,40 @@ applications, X servers (rootless or fullscreen) or other display servers.")
"weston-" version ".tar.xz"))
(sha256
(base32
- "1bsc9ry566mpk6fdwkqpvwq2j7m79d9cvh7d3lgf6igsphik98hm"))))
- (build-system gnu-build-system)
+ "04p6hal5kalmdp5dxwh2h5qhkkb4dvbsk7l091zvvcq70slj6qsl"))))
+ (build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
("xorg-server" ,xorg-server)))
(inputs
`(("cairo" ,cairo-xcb)
+ ("colord" ,colord)
("dbus" ,dbus)
("elogind" ,elogind)
+ ("lcms" ,lcms)
+ ("libevdev" ,libevdev)
("libinput" ,libinput-minimal)
+ ("libjpeg" ,libjpeg)
("libunwind" ,libunwind)
+ ("libva" ,libva)
+ ("libwebp" ,libwebp)
("libxcursor" ,libxcursor)
("libxkbcommon" ,libxkbcommon)
+ ("libxml2" ,libxml2)
("mesa" ,mesa)
("mtdev" ,mtdev)
("linux-pam" ,linux-pam)
+ ("pango" ,pango)
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)
("xorg-server-xwayland" ,xorg-server-xwayland)))
(arguments
`(#:configure-flags
- (list "--disable-setuid-install"
- "--enable-systemd-login"
- (string-append "--with-xserver-path="
+ (list "-Dbackend-rdp=false" ; TODO: Enable.
+ "-Dremoting=false" ; TODO: Enable.
+ "-Dsimple-dmabuf-drm=auto"
+ "-Dsystemd=false"
+ (string-append "-Dxwayland-path="
(assoc-ref %build-inputs "xorg-server-xwayland")
"/bin/Xwayland"))
#:parallel-tests? #f ; Parallel tests cause failures.
@@ -668,8 +681,8 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(add-before 'configure 'use-elogind
(lambda _
;; Use elogind instead of systemd
- (substitute* "configure"
- (("libsystemd-login >= 198") "libelogind"))
+ (substitute* "libweston/meson.build"
+ (("libsystemd-login") "libelogind"))
(substitute* '("libweston/launcher-logind.c"
"libweston/weston-launch.c")
(("#include <systemd/sd-login.h>")
@@ -677,7 +690,8 @@ applications, X servers (rootless or fullscreen) or other display servers.")
#t))
(add-after 'configure 'patch-confdefs.h
(lambda _
- (system "echo \"#define HAVE_SYSTEMD_LOGIN_209 1\" >> confdefs.h")))
+ (system "echo \"#define HAVE_SYSTEMD_LOGIN_209 1\" >> confdefs.h")
+ #t))
(add-before 'check 'setup
(lambda _
(setenv "HOME" (getcwd))
@@ -906,7 +920,7 @@ interfaces, based on the useradd, usermod and userdel commands.")
(define-public libmbim
(package
(name "libmbim")
- (version "1.18.0")
+ (version "1.18.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -914,7 +928,7 @@ interfaces, based on the useradd, usermod and userdel commands.")
name "-" version ".tar.xz"))
(sha256
(base32
- "10mjjy860aakfd3h1yaj9l1jw816amrpwmyqlx37j21xv0l03x3c"))))
+ "0s4jsfsydp2vykv7lnimalp9i680aas1qcx7zdpjiic64b5g48vp"))))
(build-system gnu-build-system)
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
@@ -937,7 +951,7 @@ which speak the Mobile Interface Broadband Model (MBIM) protocol.")
(define-public libqmi
(package
(name "libqmi")
- (version "1.22.2")
+ (version "1.22.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -945,7 +959,7 @@ which speak the Mobile Interface Broadband Model (MBIM) protocol.")
"libqmi-" version ".tar.xz"))
(sha256
(base32
- "09w20dsgr16bgbqw5ds7r6j2s6ihwyalh9zpbjhcn7cvm0afbwgi"))))
+ "1wgrrb9vb3myl8xgck8ik86876ycbg8crylybs3ssi21vrxqwnsc"))))
(build-system gnu-build-system)
(inputs
`(("libgudev" ,libgudev)))