summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-05-08 17:29:45 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-14 14:47:16 +0200
commitdec1009d8256202af9459f06eb6f58cdc3450da4 (patch)
treeb8f7074ea50cb4ba5640d047c96f65673a24803b /gnu/packages/freedesktop.scm
parentbdb6ff3ab13c94ae5b51171c4f1df87f8af398cc (diff)
downloadguix-patches-dec1009d8256202af9459f06eb6f58cdc3450da4.tar
guix-patches-dec1009d8256202af9459f06eb6f58cdc3450da4.tar.gz
gnu: Add xdg-desktop-portal-wlr.
* gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c82ad230d7..7f8da7f3e4 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -95,6 +95,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages samba)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
@@ -2330,3 +2331,35 @@ which uses GTK+ and various pieces of GNOME infrastructure, such as the
@code{org.gnome.Shell.Screenshot} or @code{org.gnome.SessionManager} D-Bus
interfaces.")
(license license:lgpl2.1+)))
+
+(define-public xdg-desktop-portal-wlr
+ (package
+ (name "xdg-desktop-portal-wlr")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/xdg-desktop-portal-wlr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18nlkqqxgxh7k0r2nk867wnp2nmaiinl6z67lrfv7rmiym0x82p8"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("cmake" ,cmake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("elogind" ,elogind)
+ ("iniparser" ,iniparser)
+ ("pipewire" ,pipewire-0.3)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://github.com/emersion/xdg-desktop-portal-wlr")
+ (synopsis "@code{xdg-desktop-portal} backend for wlroots")
+ (description
+ "This package provides @code{xdg-desktop-portal-wlr}. This project
+seeks to add support for the screenshot, screencast, and possibly
+remote-desktop @code{xdg-desktop-portal} interfaces for wlroots based
+compositors.")
+ (license license:expat)))