summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-08 19:32:17 +0100
committerMarius Bakke <marius@gnu.org>2023-01-08 19:32:17 +0100
commitda91e790fdf4053a1503738e69f88c4b2054b096 (patch)
tree27f26ac3308eaa34952314a3182ffce2f5dcd51e /gnu/packages/freedesktop.scm
parent9123bb0fba3fce976dc41cd3b8919ee73b4cee4d (diff)
parent8cca1a35bc42cddb7e0586062d192197520042d5 (diff)
downloadguix-patches-da91e790fdf4053a1503738e69f88c4b2054b096.tar
guix-patches-da91e790fdf4053a1503738e69f88c4b2054b096.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm102
1 files changed, 98 insertions, 4 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index bd90a76086..cc3e263df0 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -94,12 +94,12 @@
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages hunspell)
#:use-module (gnu packages ibus)
#:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages language)
#:use-module (gnu packages libffi)
- #:use-module (gnu packages libreoffice)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
@@ -995,6 +995,66 @@ backends, PackageKit can perform these tasks using the appropriate package
manager for the current system.")
(license license:gpl2+)))
+(define-public power-profiles-daemon
+ (package
+ (name "power-profiles-daemon")
+ (version "0.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/hadess/power-profiles-daemon")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wqcajbj358zpyj6y4h1v34y2yncq76wqxd0jm431habcly0bqyr"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Dsystemdsystemunitdir=false")
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'fake-pkexec
+ (lambda _ (setenv "PKEXEC_UID" "-1")))
+ (add-before 'configure 'correct-polkit-dir
+ (lambda _
+ (substitute* "meson.build"
+ (("polkit_gobject_dep\\..*")
+ (string-append "'" #$output "/share/polkit-1/actions'")))))
+ (add-after 'install 'wrap-program
+ (lambda _
+ (wrap-program
+ (string-append #$output "/bin/powerprofilesctl")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+ (native-inputs
+ (list `(,glib "bin") gobject-introspection pkg-config python vala))
+ (inputs
+ (list bash-minimal ;for 'wrap-program'
+ dbus
+ dbus-glib
+ libgudev
+ glib polkit
+ python
+ python-pygobject
+ upower))
+ (home-page "https://gitlab.freedesktop.org/hadess/power-profiles-daemon")
+ (synopsis "Power profile handling over D-Bus")
+ (description
+ "power-profiles-daemon offers to modify system behaviour based upon
+user-selected power profiles. There are 3 different power profiles, a
+\"balanced\" default mode, a \"power-saver\" mode, as well as a
+\"performance\" mode. The first 2 of those are available on every system.
+The \"performance\" mode is only available on select systems and is
+implemented by different \"drivers\" based on the system or systems it
+targets. In addition to those 2 or 3 modes (depending on the system),
+\"actions\" can be hooked up to change the behaviour of a particular device.
+For example, this can be used to disable the fast-charging for some USB
+devices when in power-saver mode.")
+ (license license:gpl3)))
+
+
(define-public python-libevdev
(package
(name "python-libevdev")
@@ -1282,7 +1342,7 @@ compositor.")
mtdev
linux-pam
pango
- pipewire-0.3
+ pipewire
wayland-protocols-next
xorg-server-xwayland))
(propagated-inputs
@@ -2500,6 +2560,40 @@ Currently supported:
@end itemize")
(license license:isc)))
+(define-public flatpak-xdg-utils
+ (package
+ (name "flatpak-xdg-utils")
+ (version "1.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flatpak/flatpak-xdg-utils")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q8wsc46fcjm737hz10jvgci5wl9sz8hj9aix2y2zdj11bqib9af"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "dbus-run-session" "--" "meson" "test"
+ "--print-errorlogs")))))))
+ (inputs (list glib))
+ (native-inputs (list dbus pkg-config))
+ (synopsis
+ "Simple portal-based commandline tools for use inside sandboxes")
+ (description
+ "This package contains a number of commandline utilities for use inside
+Flatpak sandboxes and other containers, like @command{guix shell --container}.
+They work by talking to portals. Currently, there is flatpak-spawn for
+running commands in sandboxes as well as xdg-open and xdg-email, which are
+compatible with the well-known scripts of the same name.")
+ (home-page "https://github.com/flatpak/flatpak-xdg-utils")
+ (license (list license:lgpl2.0+ license:lgpl2.1+))))
+
(define-public libportal
(package
(name "libportal")
@@ -2569,7 +2663,7 @@ Currently supported:
("libportal" ,libportal)
("dbus" ,dbus)
("geoclue" ,geoclue)
- ("pipewire" ,pipewire-0.3)
+ ("pipewire" ,pipewire)
("fuse" ,fuse-3)))
(arguments
`(#:configure-flags
@@ -2742,7 +2836,7 @@ for xdg-desktop-portal that is using Qt/KF5.")
grim
iniparser
libinih
- pipewire-0.3
+ pipewire
slurp
wayland
wayland-protocols))