summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2020-09-27 15:35:02 +1000
committerLudovic Courtès <ludo@gnu.org>2020-09-29 22:53:36 +0200
commitd94be771fc2a96b7290f7b43aee2f042cbcd6ded (patch)
tree7e52ce3fee21db0b6289eeaecdfbf267650e939f /gnu/packages/freedesktop.scm
parent680b80e37453d4e23ad8188d60894916e1c07162 (diff)
downloadguix-patches-d94be771fc2a96b7290f7b43aee2f042cbcd6ded.tar
guix-patches-d94be771fc2a96b7290f7b43aee2f042cbcd6ded.tar.gz
gnu: wev: Use version tag instead of commit.
* gnu/packages/freedesktop.scm (wev): Update to the 1.0.0 version tag, which happens to be the same commit anyway. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm64
1 files changed, 31 insertions, 33 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 721feb1e69..cfb87178fb 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -909,41 +909,39 @@ multiplexer to the KMS/DRM Linux kernel devices.")
(license license:expat)))
(define-public wev
- ;; There simple tool has no version or release yet.
- (let ((commit "cee3dfb2a8b40ee303611018c68ae182d84a7f46"))
- (package
- (name "wev")
- (version (string-append "2020-02-06-" (string-take commit 8)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~sircmpwn/wev")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0l71v3fzgiiv6xkk365q1l08qvaymxd4kpaya6r2g8yzkr7i2hms"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("scdoc" ,scdoc)))
- (inputs
- `(("libxkbcommon" ,libxkbcommon)
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)))
- (home-page "https://git.sr.ht/~sircmpwn/wev")
- (synopsis "Wayland event viewer")
- (description "Wev is a tool that opens a window, printing all events
+ (package
+ (name "wev")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/wev")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l71v3fzgiiv6xkk365q1l08qvaymxd4kpaya6r2g8yzkr7i2hms"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://git.sr.ht/~sircmpwn/wev")
+ (synopsis "Wayland event viewer")
+ (description "Wev is a tool that opens a window, printing all events
sent to a Wayland window, such as key presses. It is analogous to the X11 tool
XEv.")
- (license license:expat))))
+ (license license:expat)))
(define-public exempi
(package