summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-26 08:59:39 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:38 +0000
commitd680ec00b9b7c2d93e8a5859b22df342e09c3a8f (patch)
treeebb9db03acb4776ebd944aeeca59081f5af2b2af /gnu/packages/freedesktop.scm
parentd0bfb36a0a75beb61683bda1bd8bd849b297e844 (diff)
downloadguix-patches-d680ec00b9b7c2d93e8a5859b22df342e09c3a8f.tar
guix-patches-d680ec00b9b7c2d93e8a5859b22df342e09c3a8f.tar.gz
gnu: accountsservice: Update to 0.6.55.
* gnu/packages/freedesktop.scm (accountsservice): Update to 0.6.55. [source]: Wrap the URI. [build-system]: Switch to meson-build-system. [arguments]: Fix configure-flags. Remove trailing #t. Fix the 'pre-configure phase and wrap it. [inputs]: Add dbus. [description]: Wrap it.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm47
1 files changed, 26 insertions, 21 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f5afb3969d..50364a50ee 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1393,57 +1393,62 @@ message bus.")
(define-public accountsservice
(package
(name "accountsservice")
- (version "0.6.50")
+ (version "0.6.55")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.freedesktop.org/software/"
- "accountsservice/accountsservice-" version ".tar.xz"))
+ "accountsservice/accountsservice-"
+ version ".tar.xz"))
(sha256
- (base32 "0jn7vg1z4vxnna0hl33hbcb4bb3zpilxc2vyclh24vx4vvsjhn83"))))
- (build-system gnu-build-system)
+ (base32 "16wwd633jak9ajyr1f1h047rmd09fhf3kzjz6g5xjsz0lwcj8azz"))))
+ (build-system meson-build-system)
(arguments
'(#:tests? #f ; XXX: tests require DocBook 4.1.2
#:configure-flags
'("--localstatedir=/var"
- "--disable-systemd"
- "--enable-elogind")
+ "-Dsystemdsystemunitdir=/tmp/empty"
+ "-Dsystemd=false"
+ "-Delogind=true")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-/bin/cat
(lambda _
(substitute* "src/user.c"
- (("/bin/cat") (which "cat")))
- #t))
+ (("/bin/cat") (which "cat")))))
(add-before
'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
- ;; Don't try to create /var/lib/AccountsService.
- (substitute* "src/Makefile.in"
- (("\\$\\(MKDIR_P\\).*/lib/AccountsService.*") "true"))
+ (substitute* "meson_post_install.py"
+ (("in dst_dirs") "in []"))
(let ((shadow (assoc-ref inputs "shadow")))
(substitute* '("src/user.c" "src/daemon.c")
- (("/usr/sbin/usermod") (string-append shadow "/sbin/usermod"))
- (("/usr/sbin/useradd") (string-append shadow "/sbin/useradd"))
- (("/usr/sbin/userdel") (string-append shadow "/sbin/userdel"))
- (("/usr/bin/passwd") (string-append shadow "/bin/passwd"))
- (("/usr/bin/chage") (string-append shadow "/bin/chage"))))
- #t)))))
+ (("/usr/sbin/usermod")
+ (string-append shadow "/sbin/usermod"))
+ (("/usr/sbin/useradd")
+ (string-append shadow "/sbin/useradd"))
+ (("/usr/sbin/userdel")
+ (string-append shadow "/sbin/userdel"))
+ (("/usr/bin/passwd")
+ (string-append shadow "/bin/passwd"))
+ (("/usr/bin/chage")
+ (string-append shadow "/bin/chage")))))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for gdbus-codegen, etc.
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("elogind" ,elogind)
+ `(("dbus" ,dbus)
+ ("elogind" ,elogind)
("polkit" ,polkit)
("shadow" ,shadow)))
(home-page "https://www.freedesktop.org/wiki/Software/AccountsService/")
(synopsis "D-Bus interface for user account query and manipulation")
(description
- "The AccountService project provides a set of D-Bus interfaces for querying
-and manipulating user account information and an implementation of these
-interfaces, based on the useradd, usermod and userdel commands.")
+ "The AccountService project provides a set of D-Bus interfaces for
+querying and manipulating user account information and an implementation of
+these interfaces, based on the useradd, usermod and userdel commands.")
(license license:gpl3+)))
(define-public libmbim