summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 15:29:39 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:09 +0000
commitbe58507d5d7f36da4c68bad2603c0a5b08858e1d (patch)
tree5eabf4b93715341cd5aa08ec8df3bd9946aaeb8c /gnu/packages/freedesktop.scm
parentd979c916e84fcf6f75d5645e318aa1cd7024be5e (diff)
downloadguix-patches-be58507d5d7f36da4c68bad2603c0a5b08858e1d.tar
guix-patches-be58507d5d7f36da4c68bad2603c0a5b08858e1d.tar.gz
gnu: wayland: Find docbook-xml when cross-compiling.
* gnu/packages/freedesktop.scm (wayland)[arguments]<#:phases>{patchdocbook-xml}: Look in 'native-inputs' instead of 'inputs' when cross-compiling.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index ba0281b694..550253bc34 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -983,14 +983,22 @@ Python.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-docbook-xml
- (lambda* (#:key inputs #:allow-other-keys)
+ ;; TODO(core-updates): Use 'native-inputs' unconditionally
+ (lambda* (#:key ,@(if (%current-target-system)
+ '(native-inputs)
+ '())
+ inputs #:allow-other-keys)
(with-directory-excursion "doc"
(substitute* (find-files "." "\\.xml$")
(("http://www.oasis-open.org/docbook/xml/4\\.5/")
- (string-append (assoc-ref inputs "docbook-xml")
+ (string-append (assoc-ref ,(if (%current-target-system)
+ '(or native-inputs inputs)
+ 'inputs) "docbook-xml")
"/xml/dtd/docbook/"))
(("http://www.oasis-open.org/docbook/xml/4\\.2/")
- (string-append (assoc-ref inputs "docbook-xml-4.2")
+ (string-append (assoc-ref ,(if (%current-target-system)
+ '(or native-inputs inputs)
+ 'inputs) "docbook-xml-4.2")
"/xml/dtd/docbook/"))))
#t))
(add-after 'install 'move-doc