summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-11 12:56:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-11 17:48:01 +0100
commitb45ae3bd28b2134fdecac3eef53a54f78795bc93 (patch)
tree94e7d83e380becd46d36a699056d412ce16e31eb /gnu/packages/freedesktop.scm
parentc26a016e97ec9747e166bd5b58c9f3d53e0f1f17 (diff)
downloadguix-patches-b45ae3bd28b2134fdecac3eef53a54f78795bc93.tar
guix-patches-b45ae3bd28b2134fdecac3eef53a54f78795bc93.tar.gz
gnu: telepathy-idle: Update to 0.2.2.
* gnu/packages/freedesktop.scm (telepathy-idle): Update to 0.2.2. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf, automake, and libootl.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6caff14cf2..94ec2cd44a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1393,17 +1393,22 @@ different sorts of messages in different formats.")
(define-public telepathy-idle
(package
(name "telepathy-idle")
- (version "0.2.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://telepathy.freedesktop.org/releases/"
- name "/" name "-" version ".tar.bz2"))
- (sha256
- (base32
- "1argdzbif1vdmwp5vqbgkadq9ancjmgdm2ncp0qfckni715ss4rh"))))
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TelepathyIM/telepathy-idle")
+ (commit (string-append "telepathy-idle-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pfw4g2cicw3ykxhsy743r0fc1yqbdrqxh2c5ha6am19dajcr95l"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("xsltproc" ,libxslt)
("python" ,python-2)