summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-29 22:34:57 +0200
committerMarius Bakke <marius@gnu.org>2021-07-29 22:34:57 +0200
commitb029be2ee0f81cdcbc14240ff426408085ab0a40 (patch)
treeed6d0e1bfdadfd28e1eb804e43763b793baa0b42 /gnu/packages/freedesktop.scm
parentbc55f3091bac4677df0cf020381c554921fea179 (diff)
parentffb381856d0c6cc1a557b789f6b377cfa17002a0 (diff)
downloadguix-patches-b029be2ee0f81cdcbc14240ff426408085ab0a40.tar
guix-patches-b029be2ee0f81cdcbc14240ff426408085ab0a40.tar.gz
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/bioinformatics.scm gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/emacs-xyz.scm gnu/packages/gpodder.scm gnu/packages/music.scm gnu/packages/patches/glibc-bootstrap-system.patch gnu/packages/python-xyz.scm gnu/packages/shells.scm gnu/packages/statistics.scm
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm45
1 files changed, 32 insertions, 13 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3e052a5697..4342a59b2a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages glib) ;intltool
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages graph)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
@@ -96,6 +97,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages rdesktop)
#:use-module (gnu packages samba)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages valgrind)
@@ -1065,7 +1067,7 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
(define-public weston
(package
(name "weston")
- (version "6.0.1")
+ (version "9.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1073,43 +1075,60 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
"weston-" version ".tar.xz"))
(sha256
(base32
- "1d2m658ll8x7prlsfk71qgw89c7dz6y7d6nndfxwl49fmrd6sbxz"))))
+ "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
(build-system meson-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("mscgen" ,mscgen)
+ ("pkg-config" ,pkg-config)
("xorg-server" ,xorg-server)))
(inputs
`(("cairo" ,cairo-xcb)
("colord" ,colord)
("dbus" ,dbus)
("elogind" ,elogind)
+ ("freerdp" ,freerdp)
+ ("glib" ,glib)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
("lcms" ,lcms)
+ ("libdrm" ,libdrm)
("libevdev" ,libevdev)
("libinput" ,libinput-minimal)
("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
("libunwind" ,libunwind)
("libva" ,libva)
("libwebp" ,libwebp)
+ ("libx11" ,libx11)
+ ("libxcb" ,libxcb)
("libxcursor" ,libxcursor)
- ("libxkbcommon" ,libxkbcommon)
("libxml2" ,libxml2)
("mesa" ,mesa)
("mtdev" ,mtdev)
("linux-pam" ,linux-pam)
("pango" ,pango)
- ("wayland" ,wayland)
+ ("pipewire" ,pipewire)
("wayland-protocols" ,wayland-protocols)
("xorg-server-xwayland" ,xorg-server-xwayland)))
+ (propagated-inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("pixman" ,pixman)
+ ("wayland" ,wayland)))
(arguments
`(#:configure-flags
- (list "-Dbackend-rdp=false" ; TODO: Enable.
- "-Dremoting=false" ; TODO: Enable.
- "-Dsimple-dmabuf-drm=auto"
- "-Dsystemd=false"
- (string-append "-Dxwayland-path="
- (assoc-ref %build-inputs "xorg-server-xwayland")
- "/bin/Xwayland"))
- #:parallel-tests? #f ; Parallel tests cause failures.
+ (list
+ ;; Otherwise, the RUNPATH will lack the final path component.
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib:"
+ (assoc-ref %outputs "out") "/lib/weston:"
+ (assoc-ref %outputs "out") "/lib/libweston-"
+ ,(version-major (package-version this-package)))
+ "-Dbackend-default=auto"
+ "-Dsystemd=false"
+ (string-append "-Dxwayland-path="
+ (assoc-ref %build-inputs "xorg-server-xwayland")
+ "/bin/Xwayland"))
+ #:parallel-tests? #f ; Parallel tests cause failures.
#:phases
(modify-phases %standard-phases
(add-before 'configure 'use-elogind