summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorRobby Zambito <contact@robbyzambito.me>2021-08-29 21:54:01 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-09-06 11:15:00 +0200
commitaced5d2608afc3ecdfa4de867333dec2b6002f55 (patch)
tree8b5fff5b5e0b0c36140452ffc0c47984d624b666 /gnu/packages/freedesktop.scm
parent32d80c2238d034e9a5ef2023abccd42e0af67260 (diff)
downloadguix-patches-aced5d2608afc3ecdfa4de867333dec2b6002f55.tar
guix-patches-aced5d2608afc3ecdfa4de867333dec2b6002f55.tar.gz
gnu: Add waypipe.
* gnu/packages/freedesktop.scm (waypipe): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 693a79c738..086707d51a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
+;;; Copyright © 2021 Robby Zambito <contact@robbyzambito.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2434,3 +2435,38 @@ seeks to add support for the screenshot, screencast, and possibly
remote-desktop @code{xdg-desktop-portal} interfaces for wlroots based
compositors.")
(license license:expat)))
+
+(define-public waypipe
+ (package
+ (name "waypipe")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/mstoeckl/waypipe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qa47ljfvb1vv3h647xwn1j5j8gfmcmdfaz4j8ygnkvj36y87vnz"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-sleep-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((coreutils (assoc-ref inputs "coreutils")))
+ (substitute* "./test/startup_failure.py"
+ (("sleep") (string-append coreutils "/bin/sleep")))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)
+ ;; For tests
+ ("python" ,python)
+ ("coreutils" ,coreutils)))
+ (home-page "https://gitlab.freedesktop.org/mstoeckl/waypipe")
+ (synopsis "Proxy for Wayland protocol applications")
+ (description
+ "Waypipe is a proxy for Wayland clients, with the aim of
+supporting behavior like @samp{ssh -X}.")
+ (license license:expat)))