summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2021-10-08 14:12:29 -0400
committerLudovic Courtès <ludo@gnu.org>2021-10-25 20:32:14 +0200
commit7c5a4025f5191f98b3b52c59f563eb2b0415c356 (patch)
treeb2354724ea9c70dcff9362b1c3e45e91baccf7ad /gnu/packages/freedesktop.scm
parent419a778e4679b63b456ec6fad5ca88f120ed9d60 (diff)
downloadguix-patches-7c5a4025f5191f98b3b52c59f563eb2b0415c356.tar
guix-patches-7c5a4025f5191f98b3b52c59f563eb2b0415c356.tar.gz
gnu: xdg-desktop-portal-gtk: Update to 1.10.0.
* gnu/packages/freedesktop.scm (xdg-desktop-portal-gtk): Update to 1.10.0. [arguments]: Adjust configure-flags for Gnome backends in new version (defaults to disabled in this version) Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 966de38d6e..e6c7266b1e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2342,16 +2342,15 @@ and others.")
(define-public xdg-desktop-portal-gtk
(package
(name "xdg-desktop-portal-gtk")
- (version "1.7.1")
+ (version "1.10.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/flatpak/xdg-desktop-portal-gtk")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/flatpak/xdg-desktop-portal-gtk/releases/download/"
+ version "/xdg-desktop-portal-gtk-" version ".tar.xz"))
(sha256
(base32
- "183iha9dxmvprn99ymgz17jx1lyn1fj5jyj6ghxl716zn9mxmird"))))
+ "0nlbnd6qvs92fanrmmn123vy0y2ml0v3ndxyk5x0cpfbnmxpa2f8"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:phases
@@ -2362,7 +2361,16 @@ and others.")
(for-each (lambda (po)
(chmod po #o666))
(find-files "po" "\\.po$"))
- #t)))))
+ #t)))
+ ;; Enable Gnome portal backends
+ #:configure-flags
+ (list
+ "--enable-appchooser"
+ "--enable-wallpaper"
+ "--enable-screenshot"
+ "--enable-screencast"
+ "--enable-background"
+ "--enable-settings")))
(native-inputs
`(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)