summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorReza Alizadeh Majd <r.majd@pantherx.org>2019-10-11 23:23:21 +0330
committerLudovic Courtès <ludo@gnu.org>2019-10-12 15:18:26 +0200
commit748ca12f97bf317fabfd0d8c2d827c1f6349187b (patch)
treefe98bcd6300be31406adcd2d7154cf6ea92f16ab /gnu/packages/freedesktop.scm
parente4892ae3678e2ce7c726bd5f0bc12a08b5678639 (diff)
downloadguix-patches-748ca12f97bf317fabfd0d8c2d827c1f6349187b.tar
guix-patches-748ca12f97bf317fabfd0d8c2d827c1f6349187b.tar.gz
gnu: Add uchardet.
* gnu/packages/freedesktop.scm (uchardet): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 8a302ba5bc..4339f14f35 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
+;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1414,3 +1415,26 @@ This package also contains two related utilities:
their MIME type.
@end itemize")
(license license:perl-license)))
+
+(define-public uchardet
+ (package
+ (name "uchardet")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.freedesktop.org/software/"
+ name "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0q9c02b6nmw41yfsiqsnphgc3f0yg3fj31wkccp47cmwvy634lc3"))))
+ (build-system cmake-build-system)
+ (home-page "https://www.freedesktop.org/wiki/Software/uchardet/")
+ (synopsis "Encoding detector library")
+ (description "uchardet is an encoding detector library, which takes a
+sequence of bytes in an unknown character encoding without any additional
+information, and attempts to determine the encoding of the text. Returned
+encoding names are iconv-compatible.")
+
+ ;; This combines code under MPL 1.1, LGPL 2.1+, and GPL 2.0+, so the
+ ;; combination is GPL 2.0+.
+ (license license:gpl2+)))