summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-15 23:45:34 +0100
committerMarius Bakke <marius@gnu.org>2020-11-15 23:45:34 +0100
commit4e5e05d40908e9f1336ffc5a6c4928ab61ad034c (patch)
treead6d6be0ece396ba3353871a5691e514253508f8 /gnu/packages/freedesktop.scm
parent2c400ae94207b3b84fcdcaa21c122076c050d307 (diff)
parente1fa3ea9fe8d01dd124c5e304bde9243876378ba (diff)
downloadguix-patches-4e5e05d40908e9f1336ffc5a6c4928ab61ad034c.tar
guix-patches-4e5e05d40908e9f1336ffc5a6c4928ab61ad034c.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7b2a8d8bb3..731737a820 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1385,17 +1385,22 @@ different sorts of messages in different formats.")
(define-public telepathy-idle
(package
(name "telepathy-idle")
- (version "0.2.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://telepathy.freedesktop.org/releases/"
- name "/" name "-" version ".tar.bz2"))
- (sha256
- (base32
- "1argdzbif1vdmwp5vqbgkadq9ancjmgdm2ncp0qfckni715ss4rh"))))
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TelepathyIM/telepathy-idle")
+ (commit (string-append "telepathy-idle-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pfw4g2cicw3ykxhsy743r0fc1yqbdrqxh2c5ha6am19dajcr95l"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("xsltproc" ,libxslt)
("python" ,python-2)