summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-13 23:04:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-13 23:04:06 +0200
commit378ebc048c033744b4f1dc13e16f4f2277d7529f (patch)
tree8411f2a9348d47858b2aca849377e91ea7f90833 /gnu/packages/freedesktop.scm
parentd99e7ee0f2bbe4abe08552afaa9821036da2a760 (diff)
parent64855281c18bab87a61c77a18c9001e6e222fb08 (diff)
downloadguix-patches-378ebc048c033744b4f1dc13e16f4f2277d7529f.tar
guix-patches-378ebc048c033744b4f1dc13e16f4f2277d7529f.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index ab3d028214..3aa88337c8 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
+;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1414,3 +1415,26 @@ This package also contains two related utilities:
their MIME type.
@end itemize")
(license license:perl-license)))
+
+(define-public uchardet
+ (package
+ (name "uchardet")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.freedesktop.org/software/"
+ name "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0q9c02b6nmw41yfsiqsnphgc3f0yg3fj31wkccp47cmwvy634lc3"))))
+ (build-system cmake-build-system)
+ (home-page "https://www.freedesktop.org/wiki/Software/uchardet/")
+ (synopsis "Encoding detector library")
+ (description "uchardet is an encoding detector library, which takes a
+sequence of bytes in an unknown character encoding without any additional
+information, and attempts to determine the encoding of the text. Returned
+encoding names are iconv-compatible.")
+
+ ;; This combines code under MPL 1.1, LGPL 2.1+, and GPL 2.0+, so the
+ ;; combination is GPL 2.0+.
+ (license license:gpl2+)))