summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-20 15:21:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-02-20 15:22:52 +0200
commit1dc98567c619866cdf1a8e14941d1badc3b9eea3 (patch)
tree2742579c2abf9db9484d9d5b458c30008fa428c8 /gnu/packages/freedesktop.scm
parenta7ad525a50d45ac93ea6d8153d9716df09bc8ab2 (diff)
downloadguix-patches-1dc98567c619866cdf1a8e14941d1badc3b9eea3.tar
guix-patches-1dc98567c619866cdf1a8e14941d1badc3b9eea3.tar.gz
gnu: elogind: Build without kexec-tools on riscv64-linux.
* gnu/packages/freedesktop.scm (elogind)[arguments]: Only reference kexec-tools when not building for riscv64-linux. [inputs]: Only include kexec-tools when not building for riscv64-linux.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm35
1 files changed, 22 insertions, 13 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f89ec0742f..6215a46cb4 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015-2017, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2017, 2018, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2016, 2017, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
@@ -585,11 +585,15 @@ the freedesktop.org XDG Base Directory specification.")
(sysconf (string-append out "/etc"))
(libexec (string-append out "/libexec/elogind"))
(dbuspolicy (string-append out "/etc/dbus-1/system.d"))
- (kexec-tools #$(this-package-input "kexec-tools"))
+ #$@(if (not (target-riscv64?))
+ #~((kexec-tools #$(this-package-input "kexec-tools")))
+ #~())
(shadow #$(this-package-input "shadow"))
(shepherd #$(this-package-input "shepherd"))
(halt-path (string-append shepherd "/sbin/halt"))
- (kexec-path (string-append kexec-tools "/sbin/kexec"))
+ #$@(if (not (target-riscv64?))
+ #~((kexec-path (string-append kexec-tools "/sbin/kexec")))
+ #~())
(nologin-path (string-append shadow "/sbin/nologin"))
(poweroff-path (string-append shepherd "/sbin/shutdown"))
(reboot-path (string-append shepherd "/sbin/reboot")))
@@ -601,7 +605,9 @@ the freedesktop.org XDG Base Directory specification.")
(string-append "-Dc_link_args=-Wl,-rpath=" libexec)
(string-append "-Dcpp_link_args=-Wl,-rpath=" libexec)
(string-append "-Dhalt-path=" halt-path)
- (string-append "-Dkexec-path=" kexec-path)
+ #$@(if (not (target-riscv64?))
+ #~((string-append "-Dkexec-path=" kexec-path))
+ #~())
(string-append "-Dpoweroff-path=" poweroff-path)
(string-append "-Dreboot-path=" reboot-path)
(string-append "-Dnologin-path=" nologin-path)
@@ -675,15 +681,18 @@ the freedesktop.org XDG Base Directory specification.")
("python" ,python)
("xsltproc" ,libxslt)))
(inputs
- (list kexec-tools
- linux-pam
- libcap
- shadow ;for 'nologin'
- shepherd ;for 'halt' and 'reboot', invoked
- ;when pressing the power button
- dbus
- eudev
- acl)) ;to add individual users to ACLs on /dev nodes
+ (append
+ (if (not (target-riscv64?))
+ (list kexec-tools)
+ '())
+ (list linux-pam
+ libcap
+ shadow ; for 'nologin'
+ shepherd ; for 'halt' and 'reboot', invoked
+ ; when pressing the power button
+ dbus
+ eudev
+ acl))) ; to add individual users to ACLs on /dev nodes
(home-page "https://github.com/elogind/elogind")
(synopsis "User, seat, and session management service")
(description "Elogind is the systemd project's \"logind\" service,