summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 12:12:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:19 +0100
commit15dc8ed5f403368099292bf51c18a0a10e0a39dc (patch)
treec6bc1483b90a3f6c410ad1e53ee3b933fc777cd4 /gnu/packages/freedesktop.scm
parentfbc70c97c60dfe3bbdbf525607e1fbcbb17adb24 (diff)
downloadguix-patches-15dc8ed5f403368099292bf51c18a0a10e0a39dc.tar
guix-patches-15dc8ed5f403368099292bf51c18a0a10e0a39dc.tar.gz
gnu: libxdg-basedir: Don't run autogen.sh manually.
* gnu/packages/freedesktop.scm (libxdg-basedir)[arguments]: Rename "autogen" phase to "patch-autogen"; remove invocation of "autogen.sh" script as it will be executed in the "bootstrap" phase.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 86222017cf..d85e8fc701 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2017 Andy Wingo <wingo@pobox.com>
;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
@@ -209,12 +209,12 @@ other applications that need to directly deal with input devices.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autogen
+ (add-after 'unpack 'patch-autogen
(lambda _
;; Run 'configure' in its own phase, not now.
(substitute* "autogen.sh"
(("^.*\\./configure.*") ""))
- (zero? (system* "sh" "autogen.sh")))))))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)