summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-21 11:35:25 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:53:57 +0200
commit08684798a8b51f0ce618860c2aeae7db5d70be63 (patch)
tree44144f273baa73e89555840d9df4e4067fb04c2c /gnu/packages/freedesktop.scm
parentbd8a6a89f07b539041ac9b5d49371f8a74d46cc3 (diff)
downloadguix-patches-08684798a8b51f0ce618860c2aeae7db5d70be63.tar
guix-patches-08684798a8b51f0ce618860c2aeae7db5d70be63.tar.gz
gnu: Add malcontent.
* gnu/packages/freedesktop.scm (malcontent): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7da6de3e99..6b70fd0ea2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -140,6 +140,61 @@ tests.")
(home-page "https://gitlab.gnome.org/pwithnall/libglib-testing")
(license license:lgpl2.1+)))
+(define-public malcontent
+ (package
+ (name "malcontent")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/pwithnall/malcontent.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vnf0pk516fwwh41v96c29l2i7h1pnwhivlkbf53kkx1q35g7lb3"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ ;; AppInfo not available inside build environment.
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* "libmalcontent/tests/app-filter.c"
+ (("g_test_add_func \\(\"/app-filter/appinfo\", test_app_filter_appinfo\\);")
+ ""))
+ #t)))))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("itstool" ,itstool)
+ ("libglib-testing" ,libglib-testing)
+ ("libxml2" ,libxml2)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("accountsservice" ,accountsservice)
+ ("appstream-glib" ,appstream-glib)
+ ("dbus" ,dbus)
+ ("flatpak" ,flatpak)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libostree" ,libostree)
+ ("linux-pam" ,linux-pam)
+ ("polkit" ,polkit)))
+ (synopsis "Parental controls support")
+ (description "MalContent implements parental controls support which can
+be used by applications to filter or limit the access of child accounts to
+inappropriate content.")
+ (home-page "https://gitlab.freedesktop.org/pwithnall/malcontent")
+ (license
+ (list
+ license:gpl2+
+ license:lgpl2.1+))))
+
(define-public xdg-utils
(package
(name "xdg-utils")