summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-24 09:33:08 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:11:46 +0000
commit04380925eae70f1a2f27eb09669f4ca241d3ae2a (patch)
tree42e168802765e0de7440800f0b46c0b9e7ecd985 /gnu/packages/freedesktop.scm
parentea91371466c9e6a6b8f2facfa244afc0c3eac840 (diff)
downloadguix-patches-04380925eae70f1a2f27eb09669f4ca241d3ae2a.tar
guix-patches-04380925eae70f1a2f27eb09669f4ca241d3ae2a.tar.gz
gnu: elogind: Fix cross-compilation.
%build-inputs and friends don't exist when cross-compiling, so use some G-expology instead. * gnu/packages/freedesktop.scm (elogind)[arguments]<#:configure-flags>: Don't use '%outputs' or '%build-inputs' when cross-compiling.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3d4bc63595..9df7feffe1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -583,12 +583,20 @@ the freedesktop.org XDG Base Directory specification.")
(build-system meson-build-system)
(arguments
`(#:configure-flags
- ,#~(let* ((out (assoc-ref %outputs "out"))
+ ;; TODO(core-updates): Use #$output unconditionally.
+ ,#~(let* ((out #$(if (%current-target-system)
+ #~#$output
+ #~(assoc-ref %outputs "out")))
(sysconf (string-append out "/etc"))
(libexec (string-append out "/libexec/elogind"))
(dbuspolicy (string-append out "/etc/dbus-1/system.d"))
- (shadow (assoc-ref %build-inputs "shadow"))
- (shepherd (assoc-ref %build-inputs "shepherd"))
+ ;; TODO(core-updates): use this-package-input unconditionally.
+ (shadow #$(if (%current-target-system)
+ (this-package-input "shadow")
+ #~(assoc-ref %build-inputs "shadow")))
+ (shepherd #$(if (%current-target-system)
+ (this-package-input "shepherd")
+ #~(assoc-ref %build-inputs "shepherd")))
(halt-path (string-append shepherd "/sbin/halt"))
(kexec-path "") ;not available in Guix yet
(nologin-path (string-append shadow "/sbin/nologin"))