summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-01-15 13:56:49 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-15 16:46:45 +0100
commiteccd3f6d2ef09fcfccf5e4e09be13b79089c60d1 (patch)
tree214e7146c6ce994d9256334f944c4524d1a363d7 /gnu/packages/fpga.scm
parent72dd271cee8d38349b43d8a1a4fd5b6942952a42 (diff)
downloadguix-patches-eccd3f6d2ef09fcfccf5e4e09be13b79089c60d1.tar
guix-patches-eccd3f6d2ef09fcfccf5e4e09be13b79089c60d1.tar.gz
gnu: arachne-pnr: Fix tests.
* gnu/packages/fpga.scm (arachne-pnr)[arguments]: Add #:make-flags. <#:phases>[configure]: Remove Makefile substitution.
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 4646d3241d..46edda02d2 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -274,16 +274,14 @@ Includes the actual FTDI connector.")
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
+ #:make-flags
+ (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ (string-append "ICEBOX=" (string-append
+ (assoc-ref %build-inputs "icestorm")
+ "/share/icebox")))
#:phases (modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs inputs #:allow-other-keys)
- (substitute* '("Makefile")
- (("DESTDIR = .*") (string-append "DESTDIR = "
- (assoc-ref outputs "out")
- "\n"))
- (("ICEBOX = .*") (string-append "ICEBOX = "
- (assoc-ref inputs "icestorm")
- "/share/icebox\n")))
(substitute* '("./tests/fsm/generate.py"
"./tests/combinatorial/generate.py")
(("#!/usr/bin/python") "#!/usr/bin/python2"))