summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorAmin Bandali <bandali@gnu.org>2019-01-13 10:07:11 -0500
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-15 16:46:43 +0100
commite82baf69f18f42b58e8929000ca4b665a74d86b4 (patch)
treeeee53cdae6e40f50602e571ee47318f4384c3a5c /gnu/packages/fpga.scm
parent357b9f9d71464180ca78f58abf3a2810ccb589f3 (diff)
downloadguix-patches-e82baf69f18f42b58e8929000ca4b665a74d86b4.tar
guix-patches-e82baf69f18f42b58e8929000ca4b665a74d86b4.tar.gz
gnu: arachne-pnr: Update to 840bdfdeb.
* gnu/packages/fpga.scm (arachne-pnr): Update to 840bdfdeb.
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 9ab2e35255..07547c6a56 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -256,20 +257,20 @@ Includes the actual FTDI connector.")
(license license:isc))))
(define-public arachne-pnr
- (let ((commit "52e69ed207342710080d85c7c639480e74a021d7")
- (revision "1"))
+ (let ((commit "840bdfdeb38809f9f6af4d89dd7b22959b176fdd")
+ (revision "2"))
(package
(name "arachne-pnr")
(version (string-append "0.0-" revision "-" (string-take commit 9)))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/cseed/arachne-pnr.git")
+ (url "https://github.com/YosysHQ/arachne-pnr.git")
(commit commit)))
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "15bdw5yxj76lxrwksp6liwmr6l1x77isf4bs50ys9rsnmiwh8c3w"))))
+ "1dqvjvgvsridybishv4pnigw9gypxh7r7nrqp9z9qq92v7c5rxzl"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -294,7 +295,7 @@ Includes the actual FTDI connector.")
("yosys" ,yosys) ; for tests
("perl" ,perl) ; for shasum
("python-2" ,python-2))) ; for tests
- (home-page "https://github.com/cseed/arachne-pnr")
+ (home-page "https://github.com/YosysHQ/arachne-pnr")
(synopsis "Place-and-Route tool for FPGAs")
(description "Arachne-PNR is a Place-and-Route Tool For FPGAs.")
(license license:gpl2))))