summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-04 18:06:42 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-04 22:09:02 +0200
commitcb9552c2aa30805bd908d9945ff7138b9066f7f4 (patch)
tree60834bf2e99134500e2b2130d1a26d4309fae2bf /gnu/packages/fpga.scm
parent039eb73b66e36fee9351fba61baf68692bcb409d (diff)
downloadguix-patches-cb9552c2aa30805bd908d9945ff7138b9066f7f4.tar
guix-patches-cb9552c2aa30805bd908d9945ff7138b9066f7f4.tar.gz
gnu: nvc: Update to 1.5.2.
* gnu/packages/fpga.scm (nvc): Update to 1.5.2. [arguments]: Don't return #t from phases.
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 9a29807b83..40cf9cc427 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -432,7 +432,7 @@ a hardware description and verification language. ")
(define-public nvc
(package
(name "nvc")
- (version "1.5.1")
+ (version "1.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -441,7 +441,7 @@ a hardware description and verification language. ")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0m1zhcqhgz5fajz98ky5zdv8g8gvk9caghqfpbv8q3mzdzahcsx5"))))
+ "1hjshyliaqi4vrw4q760rwmq6hvbpsvr2h4zl34k5j457004dy9l"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -450,8 +450,7 @@ a hardware description and verification language. ")
(modify-phases %standard-phases
(add-after 'unpack 'clean-up
(lambda _
- (delete-file "autogen.sh")
- #t)))))
+ (delete-file "autogen.sh"))))))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)