summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros.for@openmailbox.org>2017-01-14 20:31:34 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-03-10 21:15:39 +0100
commitb500dc2e83adc5529b890349af48655d0adaf1f8 (patch)
tree06b6cb2a2259cd2064674882d8ce5c72e99413fb /gnu/packages/fpga.scm
parent97bede8466b587099d5fdd4640483e82328bbd8d (diff)
downloadguix-patches-b500dc2e83adc5529b890349af48655d0adaf1f8.tar
guix-patches-b500dc2e83adc5529b890349af48655d0adaf1f8.tar.gz
gnu: icestorm: Replace reference in icebox_vlog.
* gnu/packages/fpga.scm (icestorm)[arguments]: Add phase "fix-usr-local" to replace reference to /usr/local/share.
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index f65eae8673..0b98e2db0d 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -231,6 +231,11 @@ For synthesis, the compiler generates netlists in the desired format.")
(("-I/usr/local/include") "")
(("-L/usr/local/lib") ""))
#t))
+ (add-after 'remove-usr-local 'fix-usr-local
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "icebox/icebox_vlog.py"
+ (("/usr/local/share") (string-append (assoc-ref outputs "out") "/share")))
+ #t))
(delete 'configure))))
(inputs
`(("libftdi" ,libftdi)))