summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-09-27 02:05:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-10-09 18:19:22 +0300
commitadc2f048cbd0084c22d7b1b81a6217e4a081569b (patch)
tree601a69cb83de7a8466f4a680126921c0698f5a50 /gnu/packages/fpga.scm
parentbca3797be4d471667c5f27ed4a08bcc2bbe1cbb0 (diff)
downloadguix-patches-adc2f048cbd0084c22d7b1b81a6217e4a081569b.tar
guix-patches-adc2f048cbd0084c22d7b1b81a6217e4a081569b.tar.gz
gnu: Add gtkwave.
* gnu/packages/fpga.scm (gtkwave): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index b7036b34cc..bb199096dc 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -30,10 +30,12 @@
#:use-module (gnu packages python)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libffi)
#:use-module (gnu packages zip)
#:use-module (gnu packages perl)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gperf)
#:use-module (gnu packages gawk)
#:use-module (gnu packages version-control)
#:use-module (gnu packages libftdi))
@@ -272,3 +274,38 @@ Includes the actual FTDI connector.")
(synopsis "Place-and-Route tool for FPGAs")
(description "Arachne-PNR is a Place-and-Route Tool For FPGAs.")
(license license:gpl2))))
+
+(define-public gtkwave
+ (package
+ (name "gtkwave")
+ (version "3.3.76")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://gtkwave.sourceforge.net/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vlvavszb1jwwiixiagld88agjrjg0ix8qa4xnxj4ziw0q87jbmn"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gperf" ,gperf)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("tcl" ,tcl)
+ ("tk" ,tk)
+ ("gtk+-2" ,gtk+-2)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-tcl="
+ (assoc-ref %build-inputs "tcl")
+ "/lib")
+ (string-append "--with-tk="
+ (assoc-ref %build-inputs "tk")
+ "/lib"))))
+
+ (synopsis "Waveform viewer for FPGA simulator trace files")
+ (description "This package is a waveform viewer for FPGA
+simulator trace files (FST).")
+ (home-page "http://gtkwave.sourceforge.net/")
+ ;; Exception against free government use in tcl_np.c and tcl_np.h
+ (license (list license:gpl2+ license:expat license:tcl/tk))))