summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-09-27 02:04:55 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-10-09 18:19:10 +0300
commitadba5f08deeb1826f7f927e0c697246d3ab13f29 (patch)
tree21db2812a49e06d30287ec49fdf7c949de2bfbbd /gnu/packages/fpga.scm
parent7f43ff965fc704bfbc96c0a31654e048bcae8a64 (diff)
downloadguix-patches-adba5f08deeb1826f7f927e0c697246d3ab13f29.tar
guix-patches-adba5f08deeb1826f7f927e0c697246d3ab13f29.tar.gz
gnu: Add abc.
* gnu/packages/fpga.scm (abc): New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm75
1 files changed, 75 insertions, 0 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
new file mode 100644
index 0000000000..f757a2823e
--- /dev/null
+++ b/gnu/packages/fpga.scm
@@ -0,0 +1,75 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fpga)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages tcl)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages libffi)
+ #:use-module (gnu packages zip)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gawk)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages libftdi))
+
+(define-public abc
+ (let ((commit "5ae4b975c49c")
+ (revision "1"))
+ (package
+ (name "abc")
+ (version (string-append "0.0-" revision "-" (string-take commit 9)))
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://bitbucket.org/alanmi/abc/get/" commit ".zip"))
+ (file-name (string-append name "-" version "-checkout.zip"))
+ (sha256
+ (base32
+ "1syygi1x40rdryih3galr4q8yg1w5bvdzl75hd27v1xq0l5bz3d0"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (inputs
+ `(("readline" ,readline)))
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (out-bin (string-append out "/bin")))
+ (install-file "abc" out-bin)))))))
+ (home-page "http://people.eecs.berkeley.edu/~alanmi/abc/")
+ (synopsis "Sequential logic synthesis and formal verification")
+ (description "ABC is a program for sequential logic synthesis and
+formal verification.")
+ (license
+ (license:non-copyleft "https://fedoraproject.org/wiki/Licensing:MIT#Modern_Variants")))))