summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-12-18 06:11:00 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-12-30 11:59:58 +0100
commit44a4810a752b466a4a94a0e61a58476c50878fbd (patch)
treef8f366e2dd3247ddc0df5eec7ff347d3f038e5a1 /gnu/packages/fpga.scm
parentc386de05fbcebf7c178327ca98326be20ba6ccb5 (diff)
downloadguix-patches-44a4810a752b466a4a94a0e61a58476c50878fbd.tar
guix-patches-44a4810a752b466a4a94a0e61a58476c50878fbd.tar.gz
gnu: Add python-migen.
* gnu/packages/fpga.scm (python-migen): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 50a19a00d6..96c37791f6 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (gnu packages tcl)
#:use-module (gnu packages readline)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages flex)
@@ -381,6 +383,33 @@ simulator trace files (@dfn{FST}).")
;; Exception against free government use in tcl_np.c and tcl_np.h.
(license (list license:gpl2+ license:expat license:tcl/tk))))
+(define-public python-migen
+ (package
+ (name "python-migen")
+ (version "0.9.2")
+ (source
+ (origin
+ ;; Tests fail in the PyPI tarball due to missing files.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/m-labs/migen")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kq11if64zj84gv4w1q7l16fp17xjxl2wv5hc9dibr1z3m1gy67l"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)))
+ (home-page "https://m-labs.hk/gateware/migen/")
+ (synopsis "Python toolbox for building complex digital hardware")
+ (description
+ "Migen FHDL is a Python library that replaces the event-driven
+paradigm of Verilog and VHDL with the notions of combinatorial and
+synchronous statements, has arithmetic rules that make integers always
+behave like mathematical integers, and allows the design's logic to be
+constructed by a Python program.")
+ (license license:bsd-2)))
+
(define-public python-myhdl
(package
(name "python-myhdl")