summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-11 16:09:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-11 16:09:53 +0300
commit29bf0aa324cb4d5140d660b2d0e8e678309e7881 (patch)
treefd0ffe228475a14ebc1885c5a7e134dd02c4b252 /gnu/packages/fpga.scm
parent09d18c6774c3b132b2d3365f6fce949799b13ac4 (diff)
downloadguix-patches-29bf0aa324cb4d5140d660b2d0e8e678309e7881.tar
guix-patches-29bf0aa324cb4d5140d660b2d0e8e678309e7881.tar.gz
gnu: nextpnr-ice40: Re-indent.
* gnu/packages/fpga.scm (nextpnr-ice40): Re-indent code.
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 3365f2a461..f36a5e2e97 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -262,38 +262,38 @@ Includes the actual FTDI connector.")
(define-public nextpnr-ice40
(let [(commit "fbe486df459909065d6852a7495a212dfd2accef")
(revision "1")]
- (package
- (name "nextpnr-ice40")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://github.com/YosysHQ/nextpnr")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
+ (package
+ (name "nextpnr-ice40")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://github.com/YosysHQ/nextpnr")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
"1fmxsywgs45g88ra7ips5s2niiiwrkyxdcy742ws18dfk2y4vi9c"))))
- (inputs
- `(("qtbase" ,qtbase)
- ("boost" ,boost-with-python3)
- ("yosys" ,yosys)
- ("eigen" ,eigen)
- ("python" ,python)
- ("icestorm" ,icestorm)))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags `("-DARCH=ice40"
- ,(string-append "-DICEBOX_ROOT="
- (assoc-ref %build-inputs "icestorm")
- "/share/icebox"))
- #:tests? #f))
- (synopsis "Place-and-Route tool for FPGAs")
- (description "Nextpnr aims to be a vendor neutral, timing driven,
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("boost" ,boost-with-python3)
+ ("yosys" ,yosys)
+ ("eigen" ,eigen)
+ ("python" ,python)
+ ("icestorm" ,icestorm)))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags `("-DARCH=ice40"
+ ,(string-append "-DICEBOX_ROOT="
+ (assoc-ref %build-inputs "icestorm")
+ "/share/icebox"))
+ #:tests? #f))
+ (synopsis "Place-and-Route tool for FPGAs")
+ (description "Nextpnr aims to be a vendor neutral, timing driven,
FOSS FPGA place and route tool.")
- (home-page "https://github.com/YosysHQ/nextpnr")
- (license license:expat))))
+ (home-page "https://github.com/YosysHQ/nextpnr")
+ (license license:expat))))
(define-public arachne-pnr
(let ((commit "840bdfdeb38809f9f6af4d89dd7b22959b176fdd")