summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-30 23:06:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-30 23:40:43 +0100
commit21fc352bad21c786ad334edc78fadf74c9a9bb0f (patch)
tree0c548efabf7d5b2b83635ea1a0cf6ac8d974c712 /gnu/packages/fpga.scm
parentbecee7029f843b23755e2cd884fafa563bc8f6b2 (diff)
downloadguix-patches-21fc352bad21c786ad334edc78fadf74c9a9bb0f.tar
guix-patches-21fc352bad21c786ad334edc78fadf74c9a9bb0f.tar.gz
gnu: yosys: Don't use unstable tarball.
* gnu/packages/fpga.scm (yosys)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index c9454aa324..9ab2e35255 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -121,14 +121,15 @@ For synthesis, the compiler generates netlists in the desired format.")
(name "yosys")
(version "0.7")
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/cliffordwolf/yosys/archive/"
- name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cliffordwolf/yosys.git")
+ (commit (string-append "yosys-" version))
+ (recursive? #t))) ; for the ‘iverilog’ submodule
(sha256
(base32
- "0vkfdn4phvkjqlnpqlr6q5f97bgjc3312vj5jf0vf85zqv88dy9x"))
- (file-name (string-append name "-" version "-checkout.tar.gz"))
+ "1ssrpgw0j9qlm52g1hsbb9fsww4vnwi0l7zvvky7a8w7wamddky0"))
+ (file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
'(begin