summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-04 23:16:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-04 23:16:17 +0100
commitebb7cf9e21060105d9950dd5142c0eb918083666 (patch)
tree36c1607b80d92e27fb9d09029d1d3b57a1fd5065 /gnu/packages/fontutils.scm
parent0b870f7915f5da43758753fd088a22033936dc50 (diff)
parentc2d7e800e6788277bc56f31d5836f9d507dc1506 (diff)
downloadguix-patches-ebb7cf9e21060105d9950dd5142c0eb918083666.tar
guix-patches-ebb7cf9e21060105d9950dd5142c0eb918083666.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm64
1 files changed, 63 insertions, 1 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 1d81938dec..71d7a19e1d 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -698,7 +699,7 @@ files. UFO is a file format that stores fonts source files.")
(propagated-inputs
`(("python2-fonttools" ,python2-fonttools)
("python2-ufolib" ,python2-ufolib)))
- (home-page "https://pypi.python.org/pypi/defcon")
+ (home-page "https://pypi.org/project/defcon/")
(synopsis "Flexible objects for representing @acronym{UFO, unified font object} data")
(description
"Defcon is a set of @acronym{UFO, unified font object} based objects
@@ -795,3 +796,64 @@ tools or editing configuration files by hand.
While designed primarily with the GNOME Desktop Environment in mind, it should
work well with other GTK+ desktop environments.")
(license license:gpl3+)))
+
+(define-public fntsample
+ (package
+ (name "fntsample")
+ (version "5.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/eugmes/fntsample/archive/release/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0awp4dh1g40ivzvm5xqlvcpcdw1vplrx3drjmbylr62y185vbs74"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:configure-flags
+ (list (string-append
+ "-DUNICODE_BLOCKS=" (assoc-ref %build-inputs "unicode-blocks")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'set-library-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (pdf-api2 (assoc-ref inputs "perl-pdf-api2"))
+ (intl (assoc-ref inputs "perl-libintl-perl"))
+ (perllib (string-append pdf-api2
+ "/lib/perl5/site_perl/"
+ ,(package-version perl)
+ ":" intl
+ "/lib/perl5/site_perl/"
+ ,(package-version perl))))
+ (wrap-program (string-append out "/bin/pdfoutline")
+ `("PERL5LIB" ":" prefix (,perllib)))
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gettext" ,gettext-minimal)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("glib" ,glib)
+ ("pango" ,pango)
+ ("perl-pdf-api2" ,perl-pdf-api2)
+ ("perl-libintl-perl" ,perl-libintl-perl)
+ ("unicode-blocks"
+ ,(origin
+ (method url-fetch)
+ (uri "https://unicode.org/Public/UNIDATA/Blocks.txt")
+ (file-name "unicode-blocks.txt")
+ (sha256
+ (base32
+ "1xs8fnhh48gs41wg004r7m4r2azh9khmyjjlnvyzy9c6zrd212x2"))))))
+ (home-page "https://github.com/eugmes/fntsample")
+ (synopsis "PDF and PostScript font samples generator")
+ (description "This package provides a tool that can be used to make font
+samples that show coverage of the font and are similar in appearance to
+Unicode Charts. It was developed for use with DejaVu Fonts project.")
+ (license license:gpl3+)))