summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 12:02:01 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:34 -0400
commiteba493b369e3353d757a82e116682fdd5ea90b47 (patch)
tree2bb70f024c708cd0fa79f721a005f88027a298c6 /gnu/packages/fontutils.scm
parentf11eebdd9ecfbf95ea1cb38266f66a2fb4c233ba (diff)
downloadguix-patches-eba493b369e3353d757a82e116682fdd5ea90b47.tar
guix-patches-eba493b369e3353d757a82e116682fdd5ea90b47.tar.gz
gnu: Add psautohint.
* gnu/packages/fontutils.scm (psautohint): New variable.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 9cb9caf159..e128ed1003 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -342,6 +342,49 @@ suite of the @code{psautohint} package.")
;; Code Pro, Source Serif Pro, all available under the same license.
(license license:silofl1.1)))))
+(define-public psautohint
+ (package
+ (name "psautohint")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "psautohint" version))
+ (sha256
+ (base32 "0zzz7hy1kkkjfrrm9ly2di3xv2x1ywdqhbyqy21k670jysldw3nm"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'copy-font-data
+ ;; The data is copied as it needs to be writable for the tests.
+ (lambda _
+ (copy-recursively
+ #$(this-package-native-input "psautohint-font-data")
+ "tests/integration/data")
+ (for-each make-file-writable
+ (find-files "tests/integration/data"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (propagated-inputs (list python-fonttools))
+ (native-inputs
+ (list psautohint-font-data
+ python-fs
+ python-pytest
+ python-pytest-cov
+ python-pytest-randomly
+ python-pytest-xdist
+ python-setuptools-scm
+ python-wheel))
+ (home-page "https://github.com/adobe-type-tools/psautohint")
+ (synopsis "Adobe's PostScript autohinter")
+ (description "This package provides the @command{autohinter} command that
+can be used to hint PostScript fonts. A Python wrapper is also included.")
+ (license license:asl2.0)))
+
(define-public python-ufoprocessor
(package
(name "python-ufoprocessor")