summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/fontutils.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 6796bc2bad..7d95d419cb 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -849,12 +849,12 @@ maintain the Noto Fonts project.")
(list check gcc-10 ;TODO: Remove when the default compiler is > GCC 7.
pkg-config scdoc))
(propagated-inputs
- `(;; Required by fcft.pc.
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("harfbuzz" ,harfbuzz)
- ("pixman" ,pixman)
- ("tllist" ,tllist)))
+ (list ;; Required by fcft.pc.
+ fontconfig
+ freetype
+ harfbuzz
+ pixman
+ tllist))
(synopsis "Font loading and glyph rasterization library")
(description
"@code{fcft} is a small font loading and glyph rasterization library
@@ -995,9 +995,7 @@ Unicode Charts. It was developed for use with DejaVu Fonts project.")
(base32 "1shcs5l27l7380dvacvhl8wrdq3lix0wnhzvfdh7vx2pkzjs3zk6"))))
(build-system meson-build-system)
(native-inputs
- `(("gtk-doc" ,gtk-doc/stable)
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)))
+ (list gtk-doc/stable pkg-config python-wrapper))
(inputs
(list freetype fribidi harfbuzz))
(home-page "https://github.com/HOST-Oman/libraqm")