summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-21 22:38:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-21 22:38:14 +0100
commitd7e213163b6713b653b2cf626c1e12226316ced2 (patch)
tree9d616b9cd891ef172f3902f59a0c630b20a3dd27 /gnu/packages/fontutils.scm
parent1661f09a10f2032438af6497b64457d6278edf65 (diff)
downloadguix-patches-d7e213163b6713b653b2cf626c1e12226316ced2.tar
guix-patches-d7e213163b6713b653b2cf626c1e12226316ced2.tar.gz
gnu: teckit: Use release tarball.
* gnu/packages/fontutils.scm (teckit)[source]: Use URL-FETCH. [native-inputs]: Remove AUTOCONF, AUTOMAKE and LIBTOOL.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 25ec9663c3..3e06ad982b 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -389,25 +389,20 @@ X11-system or any other graphical user interface.")
(define-public teckit
(package
(name "teckit")
- (version "2.5.8")
+ (version "2.5.8") ;signed by key 0xC9183BEA0288CDEE
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/silnrsi/teckit")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://github.com/silnrsi/teckit/releases/"
+ "download/v" version "/teckit-" version ".tar.gz"))
(sha256
- (base32 "1jmsdmfz7bgq1n5qsqgpq1b1n77f1hll0czfw5wkxz4knzb14ndn"))))
+ (base32 "00dy4hpxlf36xn9ngwy8p8hcvqjdmfzlfadihjl92dq8y5l1zprm"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)
("expat" ,expat)))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("perl" ,perl))) ; for the tests
+ `(("perl" ,perl))) ;for the tests
(synopsis "Toolkit for encoding conversions")
(description
"TECkit is a low-level toolkit intended to be used by other applications